Using RadControls in ExpressionBlend

4 posts, 0 answers
  1. Tom
    Tom avatar
    50 posts
    Member since:
    Oct 2010

    Posted 11 Jan 2011 Link to this post


    I've just started using Expression Blend for UI design, instead of using the UI editor in VS2010. However, the Radcontrols in my project are not rendered in the Blend designer window. They appear as blank boxes. Regular WPF control render correctly however.

    I've tried creating fresh projects from scratch and the same thing happens - no rendering of the Radcontrols, but standard WPF controls show up ok.

    Is this expected?

    Tom Davies
  2. Troy Goddu
    Troy Goddu avatar
    11 posts
    Member since:
    Dec 2009

    Posted 11 Jan 2011 Link to this post

    I too am interested in this question.  For WPF, the Telerik doc frequently relies on Expression Blend when explaining how to modify look and feel.  I downloaded a trial period EB 4 (I'm using VS 2010) but my experience does not follow the docs.  (Example:  Styling a Row never enables the 'copy style' option).  I've had the same result as Tom when starting from scratch, too.  Does the doc need updating?

  3. Vanya Pavlova
    Vanya Pavlova avatar
    2019 posts

    Posted 11 Jan 2011 Link to this post

    Hi Tom,

    That is really weird and we are sorry to hear that you have such problems.
    Can you please answer the following questions:

    1.What is the version of RadControls for WPF you are currently using?
    2.With which controls you are experiencing such problems or this is valid for all RadControls?
    3.Are these controls rendered correctly at runtime?
    4.Are you trying to edit some template and what is the case when you edit the template of particular RadControls.
    5.Are you sure that all references you use are with the same version?

    You may try to reinstall these controls and add the references you need manually in Expression Blend.
    Also verify that you did not have installed any older version of RadControls/WPF.

    I will be waiting for your response.

    Kind regards,
    Vanya Pavlova
    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
  4. Esteban
    Esteban avatar
    7 posts
    Member since:
    Nov 2007

    Posted 06 Nov 2012 Link to this post

    Just notating here in case anyone else has this issue (Assuming it is similar to mine).

    I had the same problem, other controls were rendering fine in Expression Blend except Telerik controls. I found this forum entry and after reading Vanya's response about reinstalling and re-referencing I figured it out.

    I had an existing VS2010 WPF application that was fine in both VS and EB. My situation was fine until I updated the Telerik library on my computer, after this, the controls wouldn't render.

    I had to close EB, go back to VS and used the Upgrade Wizard (right-click project => RadControls for WPF => Upgrade Wizard) which updated my applications Library references. EB rendered correctly after that. I'm assuming it had something to do with using old referenced libraries that ended up in the bin or something.

    GL All.
Back to Top