Upgrade question

2 posts, 1 answers
  1. Tim
    Tim avatar
    2 posts
    Member since:
    Jan 2017

    Posted 18 Jan 2017 Link to this post

    We purchased the sources for a project that used the 2009 version of UI for Winforms. We are using the current version of Winforms. The original project was created with VS 2010. It has been upgraded to VS 2015. In the project, we have the current version of the assemblies selected yet we still get the build error as seen below:

     

    Severity Code Description Project File Line Suppression State
    Error CS1705 Assembly 'Telerik.WinControls.Themes.Breeze' with identity 'Telerik.WinControls.Themes.Breeze, Version=2016.3.1024.40, Culture=neutral, PublicKeyToken=5bb2a467cbec794e' uses 'Telerik.WinControls, Version=2016.3.1024.40, Culture=neutral, PublicKeyToken=5bb2a467cbec794e' which has a higher version than referenced assembly 'Telerik.WinControls' with identity 'Telerik.WinControls, Version=2009.1.9.311, Culture=neutral, PublicKeyToken=5bb2a467cbec794e' CannaPOS C:\Users\bigdo\OneDrive\Documents\GitHub\RPOS\420TechPOS\Retail\CSC 1 Active

    We want to ship our product with the current version of WinControls.

    Thanks!


  2. Answer
    Lance | Manager Technical Support
    Admin
    Lance | Manager Technical Support avatar
    1168 posts

    Posted 18 Jan 2017 Link to this post

    Hi Tim,

    To resolve this, you can run the Automatic Upgrade Wizard, follow the steps you see in this tutorial. The wizard will also update the Themes, which should resolve the issue you're seeing.

    If you're still encountering an issue, please open a support ticket so that we can investigate further (see "Regarding Support" section below).

    Please note that a 7 year jump contains 42 releases of UI for Winforms (21 major releases and 21 Minor Releases). It is not recommended to do a direct upgrade from 2009.1 to 2016.3 as there have been many changes in that time frame. You can see all the changes here, click on the version number to see the release notes for that version.

    We recommend updating a few versions at a time and repair breaking changes along the way. The Upgrade Wizard makes this process a little easier as it automates much of the process, but it is still something that should be closely monitored as you go.


    Regarding Support

    You've submitted this inquiry as a pubic forum post and not as a Support Ticket. Although the Telerik Support Team does monitor the forums, we cannot guarantee a response.

    If you need a guaranteed support team response, please submit your issue as a Support Ticket here. Support Tickets go directly to the support engineering team responsible for the product and carry a 24 hour response guarantee.

    Please let us know if you have any further questions or concerns.

    Regards,
    Lance | Tech Support Engineer, Sr.
    Telerik by Progress
    Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Back to Top