This is a migrated thread and some comments may be shown as answers.

translations not showing in time

1 Answer 8 Views
DataFilter
This is a migrated thread and some comments may be shown as answers.
JIG
Top achievements
Rank 1
JIG asked on 09 Oct 2018, 02:00 PM

I'm using a raddatafilter in my application with an overrride of the GetStringOverride.

translations are in but it seems that when the raddatafilter is shown it doesn't show the translations right away , for the and/or logical operator i need to click first to change it and then it shows the correct translation.

Same thing for the dropdownoperators, once the dropdown is opened the first time and you delete the line and add a new one it shows the correct translations.

On initializing the CustomLocalization we set the culture to "en-US" , just in case we don't have the translation it will show the english one.

I provided some screenshots to show what i mean
Is this a bug or how should i fix this?

1 Answer, 1 is accepted

Sort by
0
Dilyan Traykov
Telerik team
answered on 12 Oct 2018, 08:48 AM
Hello Jimmy,

I tried to reproduce the issue you described in a small sample project, but the result I observed is different than the one from the screenshots you provided.

Could you please have a look at the project I attached to my reply and let me know how it differs from the setup you have at you end?

I look forward to your reply.

Regards,
Dilyan Traykov
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
DataFilter
Asked by
JIG
Top achievements
Rank 1
Answers by
Dilyan Traykov
Telerik team
Share this question
or