This is a migrated thread and some comments may be shown as answers.

Toolbox not populating after 15.0.21.224

3 Answers 26 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Gary
Top achievements
Rank 1
Gary asked on 23 Mar 2021, 06:49 PM
After updating from a 2020 version to the latest (at time of writing) 15.0.21.224, my Toolbox no longer populates with Reporting controls in VS 2019's design view. The designer of my reports load fine (.VB based ones), but the toolbox refuses to show any available controls.

I tried a repair install of reporting, as well as manually uninstalling/reinstalling with no luck.

I also tried right clicking the toolbox to choose items, and all Telerik Reporting stuff is already checked... but still not showing.

3 Answers, 1 is accepted

Sort by
0
Todor
Telerik team
answered on 26 Mar 2021, 11:47 AM

Hello Gary,

We are aware of a similar issue with the WPF Report Viewer toolbox item. It is logged in our public feedback portal - The assembly Telerik.ReportViewer.Wpf.Design.dll doesn't contain the required WPF assemblies as resources. I hope we will release it with the upcoming Service Pack 2 that we intend to deliver by the end of March 2021.

Note also that Visual Studio 2019 displays only the toolbox items for the last installed reporting version. For that reason, the older projects must be updated in order for the Toolbox items to be visible.

Regards,
Todor
Progress Telerik

Love the Telerik and Kendo UI products and believe more people should try them? Invite a fellow developer to become a Progress customer and each of you can get a $50 Amazon gift voucher.

0
Gary
Top achievements
Rank 1
answered on 26 Mar 2021, 03:52 PM
Todor,

This bug seems to be where the reporting items in general do not show up. Its not just the viewer control.

I am working in a WebAPI I am using as a report server. Trying to modify reports that are in the older .vb/.cs format that use the built-in Design View of VS. None of the reporting items at all populate in the Toolbox. For example, I can't drag an image or a section or subreport or anything from the toolbox onto my Report because they are not there.
0
Neli
Telerik team
answered on 31 Mar 2021, 02:23 PM

Hi Gary,

Thank you for your clarifications.

I would suggest testing the approach from the following KB articles:

- Telerik Reporting Missing in Visual Studio;

- Telerik Reporting wizards don't show up in VS 2017 Toolbox

You may also test to upgrade to our latest version 15.0.21.326.

Let us know if the issue is resolved.

Regards,
Neli
Progress Telerik

Love the Telerik and Kendo UI products and believe more people should try them? Invite a fellow developer to become a Progress customer and each of you can get a $50 Amazon gift voucher.

Tags
General Discussions
Asked by
Gary
Top achievements
Rank 1
Answers by
Todor
Telerik team
Gary
Top achievements
Rank 1
Neli
Telerik team
Share this question
or