This is a migrated thread and some comments may be shown as answers.

ToggleVisibility actions result in empty report

2 Answers 20 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Dmitry
Top achievements
Rank 1
Dmitry asked on 05 Aug 2013, 04:12 PM
Hello.

Using version 6.2.12.1017 with Silverlight. 
I have a cross tab report with NeedDataSource event loading report data. The report has toggle visibility actions to collapse/expand cross tab row/column groups. On my dev box everything works as expected.

Once deployed to QA environment, toggle actions result in empty report, not blank but like if no data.

After some research I found that on my dev box NeedDataSource is fired only once, toggle actions don't fire it. I guess in this case data is taken from cache. But in QA I see NeedDataSource is fired for every toggle click. In addition to in, despite of multiple event firing, report items binding doesn't work, that's why report is empty.

Could someone point me to some solution for this. I checked configuration, files, everything is the same with my dev box. Now have no idea what can cause such misbehavior.

Thanks in advance.



2 Answers, 1 is accepted

Sort by
0
Squall
Top achievements
Rank 1
answered on 06 Aug 2013, 11:31 AM
0
Dmitry
Top achievements
Rank 1
answered on 06 Aug 2013, 01:18 PM
Exactly. Thanks a lot. QA uses SQL session provider. Disabling it makes everything work. I will try to make changes acc. to design considerations to have reports working with SQL session provider.
Tags
General Discussions
Asked by
Dmitry
Top achievements
Rank 1
Answers by
Squall
Top achievements
Rank 1
Dmitry
Top achievements
Rank 1
Share this question
or