This is a migrated thread and some comments may be shown as answers.

Toggle Mark Initially expanded doesn't work for me

2 Answers 60 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
danparker276
Top achievements
Rank 2
danparker276 asked on 10 Nov 2013, 01:45 AM
The toggling works.  I'm just doing grouping and putting the action toggle visibility on a textbox in the group header and the toggle targets are the groups below. (I'm not using a table or crosstab).   It's just always expanded initially.  If I check the Initially expanded all it does it change the + to a - but all the detail items or group below items  are still displayed.  I think I'm missing something.

This report is very basic
Group 1 -- Year
Group 2 -- Month
Details -- Day  Data1 Data2 Data3

I have toggle vis on group 1 and group 2

2 Answers, 1 is accepted

Sort by
0
Accepted
Peter
Telerik team
answered on 11 Nov 2013, 04:07 PM
Hello Dan,

"Toggle mark initially expanded" checkbox defines if the item exposing the action will be rendered initially with expanded or with collapsed mark. It does not control the Visibility of the actual item. Thus if you may have to hide the group/item initially set the Visible=false and uncheck the "Toggle mark initially expanded" checkbox.

Regards,
Peter
Telerik

New HTML5/JS REPORT VIEWER with MOBILE AND TOUCH SUPPORT available in Telerik Reporting Q3 2013! Get the new Reporting version from your account or download a trial.

0
danparker276
Top achievements
Rank 2
answered on 11 Nov 2013, 05:49 PM
Ah, thank you, works great.
Tags
General Discussions
Asked by
danparker276
Top achievements
Rank 2
Answers by
Peter
Telerik team
danparker276
Top achievements
Rank 2
Share this question
or