This is a migrated thread and some comments may be shown as answers.

Theme Builder does not remember Shapes

6 Answers 42 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
ManniAT
Top achievements
Rank 2
ManniAT asked on 22 Jan 2008, 07:17 PM
Hi,

I'm working on a button looking like a plus sign.
I place a simple RadButton on my Form and choose "OpenThemeBuilder".

I select "RadButtonElement" and then the shape tool.
After doing this I try to change the shape by adding some points and building a plus sign.
It looks fine so I choose "Save Style Sheet in Theme File".
I add a theme manager to my form, load the theme - works fine.

Next I find out (after checking) that my app - that I hav to make the vertical bar a bit wider.
I open themebuilder and load the xml.
What I get is my plus-button.
So far so good.

Now again I choose RadButtonElement and then the shape tool.
PROBLEM: I get a rectangular shape instead of the plus sign.
Ok, it is not too hard to redraw a plus - but if I have a more complex shape it is extremly hard.
Aspecially when you find out "ah, just point X a bit more up" or something like this.

Is this a bug or am I simply doing something wrong?

Regards

Manfred

6 Answers, 1 is accepted

Sort by
0
Peter
Telerik team
answered on 23 Jan 2008, 09:19 AM
Hello Manfred Pohler,

We could not reproduce the scenario you are describing. Please tell us what is the behavior when using the Shape's drop down button options "Edit points...".

We are looking forward to your response.

Regards,
Peter
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
ManniAT
Top achievements
Rank 2
answered on 23 Jan 2008, 09:39 AM
Hi,

what I was trying is to do the same as initial.
So select (left) "RadButtonElement" and then the toolstrip button on the right.

This works for inital editing (createing) the shape but not on changeing an existing one.
But with your help I could solve it.

Thanks

Manfred
0
Kiril
Telerik team
answered on 23 Jan 2008, 10:04 AM
Hi Manfred,

I'm glad to hear the issue has now been addressed.
If you have any additional questions, please do not hesitate to write.

Sincerely yours,
Kiril
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Angel
Telerik team
answered on 23 Jan 2008, 06:39 PM
Sorry, Manfred, it seems that Kiril misunderstood your post.

As Peter said, we cannot reproduce the behavior you describe. I attached a theme with a "plus" shape and a movie that shows how VisualStyleBuilder loads the theme and the ShapeEditor shows the "plus" shape.

Would you describe in more details how do you achieve the disappearing shape or send us a movie (or a project) so we can see the steps to reproduce the behavior? You can do so in a new support ticket.


Sincerely yours,

Angel
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
ManniAT
Top achievements
Rank 2
answered on 23 Jan 2008, 07:32 PM
Ok,

first of all - I could make it going!

But here the steps to reproduce my "problem".
Create a new project.
Add a RadButton.
Choose "Open Theme Builder" from the context menu.
Ensure "expert view".
Choose RadButtonElement  on the control tree.
Click the "Shape" (inwriter like icon) button on the toolbar.
Move a point to somewhere and see the changed shape.
Choose "Save Style Sheet in Theme File" from the file menu.
Exit Style builder.

Back to VS - choose "new theme manager" for the context menu.
Choose "Load Theme from File" from the ThemeBuilder context menu.
Chose "Control default" on the button - and see the new shep.
Choose open Theme builder again from the buttons CM.
Theme builder opens with the new shape.
So far so good.
Now exactly as above:
Select "RadButtonElement" in the tree.
Click the Pen Toolbar button.
And see a rectangular shape in the editor.

That is what irritated me.
By selcting Shape - in the properties - and there edit points it works.
BUT not with the toolbar button!!!

Regards

Manfred
0
Angel
Telerik team
answered on 25 Jan 2008, 08:44 AM
Hi Manfred Pohler,

Thank you for the detailed steps that you gave. We reproduced the issue and it will be addressed as soon as possible.

Your Telerik points have been updated.

If you have additional questions please contact us.

Sincerely yours,
Angel
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
General Discussions
Asked by
ManniAT
Top achievements
Rank 2
Answers by
Peter
Telerik team
ManniAT
Top achievements
Rank 2
Kiril
Telerik team
Angel
Telerik team
Share this question
or