The expression contains object 'Exp1' that is not defined in the current

5 posts, 0 answers
  1. Jon
    Jon avatar
    539 posts
    Member since:
    Apr 2004

    Posted 25 Aug 2010 Link to this post


    Hi..
    I'm getting a strange error on just one of the rows in my report.    The data looks fine.


    "An error has occured while processing TextBox  txtBoxCustomer
    The expression contains object 'Exp1' that is not defined in the current"

    Any ideas?

    thanks again
  2. Peter
    Admin
    Peter avatar
    1665 posts

    Posted 30 Aug 2010 Link to this post

    Hello Jon,

    The error is indicating a missing data field. Please make sure that you have set the Data Source Component to appropriate data item (report itself, Table, List, Crosstab, Chart) and that the DataSource component (SQLDataSource component) is having a Exp1 field.

    For further assistance we will appreciate if you send a sample project that exhibits the error you have experienced.

    Regards,
    Peter
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. David
    David avatar
    3 posts
    Member since:
    Jan 2011

    Posted 21 Jan 2011 Link to this post

    Hello I'm from Germany.
    My Application Reporting works fine with Reporting Q1!
    I installed Reporting Q3-2010 and getting parameter erros, etc
    Yesterday I installed Reporting Q3-2010 SP1 and works...BUT...by EXPORT getting the error object is not defined?????? only by export, The data looks fine (see you attachment)
  4. Peter
    Admin
    Peter avatar
    1665 posts

    Posted 26 Jan 2011 Link to this post

    Hi David,

    Are you by any chance passing parameter values or make any changes to the report items through the NeedDataSource event? If this is the case, be aware that since Q3 the NeedDataSource event is meant to be used only for providing data source to the report and that data source is cached unless changed i.e. once cached the NeedDataSource event is not fired again and as you probably know every time the report is previewed, paged or exported through the viewer it is processed and rendered from scratch. During this processing, the cached data source is used, but the Values you have set in NeedDataSource are not  being set as the event is not fired second time. That is why any other changes to report items or parameters should be moved to ItemDataBinding event, which is fired regardless.

    If this is not case, we will appreciate if you open a support ticket and send us a sample runnable project to debug locally.

    Best wishes,
    Peter
    the Telerik team
    Get started with Telerik Reporting with numerous videos and detailed documentation.
  5. Manthri
    Manthri avatar
    1 posts
    Member since:
    Mar 2018

    Posted 08 Mar 2018 in reply to Peter Link to this post

    When I am trying to get he details by passing params I am getting the attached issue.

     

    Please give a sollution.

Back to Top