This is a migrated thread and some comments may be shown as answers.

Telerik Reporting Item Template is missing

1 Answer 215 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Nicholas
Top achievements
Rank 1
Nicholas asked on 03 Jun 2016, 10:35 PM

Hi, I need some help getting the Telerik Report to show up when I add a new item to a class library project.

I have followed this guide completely yet I still cant get the template to show up: http://www.telerik.com/support/kb/reporting/details/telerik-reporting-item-template-is-missing.

I am using Visual Studio 2015, and the free trial of Telerik Reporting 2016.

Thanks.

1 Answer, 1 is accepted

Sort by
0
Stef
Telerik team
answered on 06 Jun 2016, 02:32 PM
Hi Nicholas,

Please test the following:
  1. Create a standard ClassLibrary project, not the ClassLibrary(Package)  ASP.NET Core project template.
  2. Select the project note in the VS Solution Explorer and select 'Add New Item' from the context menu;
  3. Find 'Reporting' on the Left side, and then 'Telerik Report R2 2016 Wizard' from list.
The above must start Telerik Report Wizard in Visual Studio.

Other approach is to add a new project, and to select Telerik Report Library R2 2016.


In case templates are still missing, please check if the installed Visual Studio and the machine cover Telerik Reporting System Requirements. Then test to uninstall and re-install by using the MSI file and running the command suggested in Installation Problems.


Let us know how it goes. Also feel free to open a support ticket and to send us the generated log file.

Regards,
Stef
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
General Discussions
Asked by
Nicholas
Top achievements
Rank 1
Answers by
Stef
Telerik team
Share this question
or