Telerik Reporting - Lack of Error Messages

2 Answers 54 Views
Report Designer (standalone)
Chris
Top achievements
Rank 1
Chris asked on 30 Sep 2021, 06:18 PM

Recently I created a report.  The report was linked to a stored procedure in MS SQL.  When I would fire off the SPROC the data would return.  One issue I had with my SPOC was 1 column name was duplicated.  I had for example "column_1" in my output twice.  I know this is a bad design on the query, but it's even worse that telerik report designer just returns "No page to display".

The report designer lacks error messages, or anything to point to where the issue was.  Your message of No page to display is to generic.

Today I'm working with another issue.  I have a SPOC with 1 field being outputted, when I run the query in SQL it works.  When I run the in the data source setup to execute top 10, it works.  When I run the report in Preview mode, the generic error No page to display.  I have found no event logs, no information as to where I can see where the designer is getting stuck or not liking the data.  

 

2 Answers, 1 is accepted

Sort by
0
Lucio
Top achievements
Rank 1
Iron
answered on 04 Oct 2021, 10:21 PM

Hola (Hello).

Something similar happened to me until I discovered that I should set a new report property to "False" (version 2021). The property is called "SkipBlankPages". By default it is "true", and apparently this prevents error messages from appearing in the report.

 

0
Todor
Telerik team
answered on 05 Oct 2021, 11:41 AM

Hello Chris and Lucio,

Indeed, the issue is due to the new Report property "SkipBlankPages" we introduced recently. I suggest the KB article The Reports Are not Rendered or Generated Report Documents are Corrupted When the Data Set Comes Back Empty for details.

We have also a bug report for the same issue in our public feedback portal - When SkipBlankPages is True and there is an error in the report, the error message is hidden. It's already in development and we should have it fixed for the upcoming Service Pack scheduled for October 20th, 2021.

Regards,
Todor
Progress Telerik

Brand new Telerik Reporting course in Virtual Classroom - the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products. Check it out at https://learn.telerik.com/.
Chris
Top achievements
Rank 1
commented on 07 Oct 2021, 02:05 PM

I will take a look at this setting and re-create the issues that I've had. 
Chris
Top achievements
Rank 1
commented on 07 Oct 2021, 02:11 PM

From what I'm seeing so far yes, all errors will output when this is set to False.  Why would this value be here and defaulted to True since it skips output of error messages?  I'll make sure I change this on all of my reports as I create them as I wouldn't want it to skip blank while building at least.
Todor
Telerik team
commented on 08 Oct 2021, 06:36 AM

Indeed, SkipBlankPages is True by default. That is the reason for the report errors not to be shown. The errors are currently considered as non-significant content and are skipped when the property is True. We would fix that shortly and the errors would be treated as significant content and will be displayed no matter what is the value of SkipBlankPages.
Tags
Report Designer (standalone)
Asked by
Chris
Top achievements
Rank 1
Answers by
Lucio
Top achievements
Rank 1
Iron
Todor
Telerik team
Share this question
or