support.input error using latest Chrome dev build

5 posts, 0 answers
  1. Cory
    Cory avatar
    11 posts
    Member since:
    Jun 2014

    Posted 19 Aug 2014 Link to this post

    Using Kendo UI v2014.2.716, I'm seeing the following error in the latest Chrome dev build (38.0.2125.0 dev-m) when support.input is set in kendo.web.js. 

    The specified value 'test' does not conform to the required format, 'yyyy-MM-dd'.

    This doesn't fail when the type is number, but fails for all other types in the array. I also don't see this error in the latest Firefox Aurora (33.0a2 2014-08-19) or Internet Explorer 11, so I'm guessing it's related to the way the latest Chrome is validating input fields. I'm not sure if there's a way Kendo UI can modify the way it's testing for input support, but I just wanted to mention it to see if anyone else has seen this and ask what the best way forward is.
  2. Georgi Krustev
    Admin
    Georgi Krustev avatar
    3747 posts

    Posted 20 Aug 2014 Link to this post

    Hello Cory,

    The problem appears to happen only in Chrome Canary. The official Chrome browser (version 36) does not have such issues.

    Please note that we support only official browsers excluding dev versions (more information here). Nevertheless we will continue monitor this issue and if it is required, we will address it in some of the next releases of Kendo UI.

    Regards,
    Georgi Krustev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  3. Cory
    Cory avatar
    11 posts
    Member since:
    Jun 2014

    Posted 20 Aug 2014 in reply to Georgi Krustev Link to this post

    Correct, I've seen it in both Chrome dev 38 and Canary.

    I also submitted this on the Chromium issue tracker and it was merged into an existing issue they already created. I'll mention it here in case anyone is interested in following the progress.

    https://code.google.com/p/chromium/issues/detail?id=405227
  4. Akesh Gupta
    Akesh Gupta avatar
    5 posts
    Member since:
    Mar 2004

    Posted 06 Jan 2015 in reply to Cory Link to this post

    This is now being seen in Chrome 39, any update on a fix or workaround? 
  5. Georgi Krustev
    Admin
    Georgi Krustev avatar
    3747 posts

    Posted 08 Jan 2015 Link to this post

    Hello Akesh,

    According the details around the logged issue, it seems to be fixed. If you are still experiencing any issues with it, I would suggest you comment in the Chrome bug report.

    Regards,
    Georgi Krustev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
Back to Top