This is a migrated thread and some comments may be shown as answers.

SubReport Parameters Not Recognized

1 Answer 49 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Phil
Top achievements
Rank 1
Phil asked on 05 Dec 2016, 07:32 PM

I have a report with a simple table and groupings.  One cell of this report contains a sub report.  The sub report has its own data source and functions well on its own (so I know the problem is not the sub report).  When I go to connect the parameters from the sub report to the main report, I cannot find them in the 'Edit Parameters' dialog.  I should be able to open this 'Edit Parameters' dialog, click add new, and the parameters from my sub report should be populated in the drop down.  I have added the parameters pragmatically as well but they are still not recognized.

Has anyone seen this issue?

1 Answer, 1 is accepted

Sort by
0
Accepted
Katia
Telerik team
answered on 06 Dec 2016, 02:40 PM
Hi Phil,

The dropdown with parameter names in Edit Parameters dialog will only be populated after the report source is selected - check Subreport (Passing Parameters to a SubReport step 5).

If you select serialized report definition (TRDX/TRDP) as a report source for SubReport item in Visual Studio Designer, the parameter name has to be typed in manually as this type of reports needs to be deserialized first.


Regards,
Katia
Telerik by Progress
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
General Discussions
Asked by
Phil
Top achievements
Rank 1
Answers by
Katia
Telerik team
Share this question
or