This is a migrated thread and some comments may be shown as answers.

Sporadic Font Issues on generated PDF reports

2 Answers 102 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Travis
Top achievements
Rank 1
Travis asked on 17 Sep 2010, 04:33 PM
Hello,

We have had a couple of issues relating to font and our Generated Reports. Unfortunately, these issues crop up with the users of our website, and we have not been able to duplicate them locally as we do not have the same equipment as our users. Furthermore, These issues do not appear on our computers; When we receive the files, they render normally.

  1. A few months ago we came across an issue in one of our projects where, in the default PDF viewer on Mac (Preview), certain blocks of text would not show up. The fix we initially came up with was to change the font-face to a different common font (Arial to Trebuchet). This seems to work well in most cases, but from time to time, we find that a field is still empty.
  2. We received an example of one of our reports from a user today, and it looks as though some form of arbitrary text substitution has occurred. Interestingly this only appears to have happened on fields that use the Arial (default) font face. The text on the report is unreadable, and doesn't appear to have any relation to the original data (eg "CREDITOR" became "BQDCHSNQ").

Has anyone heard of or experienced these issues? Is there a fix available, or at least a reliable way to change this so it doesn't crop up anymore? I should also mention that we have disabled FontEmbedding on a number of these reports as well, so that we could keep the file sizes to a minimum.

Any information would be greatly appreciated. Thanks.

2 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 20 Sep 2010, 04:47 PM
Hello Travis,

We have made some fixed related to the font handling and embedding for PDF documents and they would be part of the upcoming service pack (released later today or tomorrow). However you're the first one to report text substitution and we're not sure how to replicate this. Our suggestion is to wait for the SP, upgrade and if the problem persists, zip and send us a sample report that exhibits the problem. Once we review it, we would be able to advise you accordingly.

All the best,
Steve
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Scott
Top achievements
Rank 2
answered on 21 Sep 2010, 03:07 PM
Could my line graph not showing up in the charts when exported be a part of this issue?

http://www.telerik.com/community/forums/reporting/telerik-reporting/exporting-report-chart-not-displaying-correctly.aspx#1352523

Thanks,
-Scott
Tags
General Discussions
Asked by
Travis
Top achievements
Rank 1
Answers by
Steve
Telerik team
Scott
Top achievements
Rank 2
Share this question
or