This is a migrated thread and some comments may be shown as answers.

Special characters inside a template

1 Answer 841 Views
Templates
This is a migrated thread and some comments may be shown as answers.
Peter Beyer
Top achievements
Rank 1
Peter Beyer asked on 09 Jun 2015, 08:47 AM

Hi,

We have the following issue when we are using Kendo UI Templates

Our application is translation labels directly into the Kendo UI Template. But when we get special characters, like we have in the danish language like æøå and ÆØÅ, it will translate it to xml codes  æøå and ÆØÅ.

Because that it is using the character #, it will break the inline code also. Do Telerik have consider a way to handle situations like this, or is the only way to take care of it, on the client site through JavaScript code.

We are aware of, that we can make a escape code \ before the #, but we hope that Telerik have a better solutions for this ?

 

Thanks

 

 

Peter Beyer

CRM-Byggefakta




1 Answer, 1 is accepted

Sort by
0
Alexander Valchev
Telerik team
answered on 11 Jun 2015, 07:21 AM
Hi Peter,

Thank you for contacting us.

The "#" symbol is part of the template syntax. The only supported way to resolve the issue is to escape the hash literals.

Regards,
Alexander Valchev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
Tags
Templates
Asked by
Peter Beyer
Top achievements
Rank 1
Answers by
Alexander Valchev
Telerik team
Share this question
or