Secondary Y-Axis for Chart (No scroll bar)

4 posts, 0 answers
  1. Houssem
    Houssem avatar
    9 posts
    Member since:
    Jun 2017

    Posted 13 Sep Link to this post

    Hi

    I have added Secondary Y-Axis for Chart but the scroll bar on the both Y-Axis is not shown anymore.

    Is there any fix for this issue?

    Thanks



  2. Martin Ivanov
    Admin
    Martin Ivanov avatar
    1402 posts

    Posted 14 Sep Link to this post

    Hello Sam,

    Can you clarify which chart you are using RadChart or RadCartesianChart?

    Note that the RadCartesianChart is displaying the panzoombar  (the scrollbar) only for the main axes (the ones set on the Vertical/HorizontalAxis property of the chart). If you don't have a main axis set the panzoombar won't be displayed.

    Also, there is a feature request for multiple axes with separate panzoombars logged in our feedback portal. You can also check the IndividualAxisZooming SDK example.

    Regards,
    Author nickname
    Progress Telerik
    Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
     


    Regards,
    Martin Ivanov
    Progress Telerik
    Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
  3. Houssem
    Houssem avatar
    9 posts
    Member since:
    Jun 2017

    Posted 29 Sep in reply to Martin Ivanov Link to this post

    Ok then while setting the vertical axis in Telerik.Windows.Controls.ChartView.CartesianSeries, the panzoombar  (the scrollbar) is not shown at all. It there a way to display it? 

    Thanks

  4. Martin Ivanov
    Admin
    Martin Ivanov avatar
    1402 posts

    Posted 04 Oct Link to this post

    Hello Sam,

    Yes, you can display the zoombar if you set also the VerticalAxis of the RadCartesianChart. If you don't want to see the chart's vertical axis you can set its ElementBrush property to Transparent. Here is an example in code:
    <telerik:RadCartesianChart>
        <telerik:RadCartesianChart.VerticalAxis>
            <telerik:LinearAxis ElementBrush="Transparent" />
        </telerik:RadCartesianChart.VerticalAxis>          
        <telerik:RadCartesianChart.HorizontalAxis>
            <telerik:CategoricalAxis/>
        </telerik:RadCartesianChart.HorizontalAxis>
        <telerik:RadCartesianChart.Behaviors>
            <telerik:ChartPanAndZoomBehavior ZoomMode="Both" />
        </telerik:RadCartesianChart.Behaviors>
        <telerik:AreaSeries>
            <telerik:AreaSeries.VerticalAxis>
                <telerik:LinearAxis />
            </telerik:AreaSeries.VerticalAxis>               
            <telerik:AreaSeries.DataPoints>
                <telerik:CategoricalDataPoint Value="20"/>
                <telerik:CategoricalDataPoint Value="40"/>
                <telerik:CategoricalDataPoint Value="35"/>
                <telerik:CategoricalDataPoint Value="40"/>
                <telerik:CategoricalDataPoint Value="30"/>
                <telerik:CategoricalDataPoint Value="50"/>
            </telerik:AreaSeries.DataPoints>
        </telerik:AreaSeries>
    </telerik:RadCartesianChart>

    Regards,
    Martin Ivanov
    Progress Telerik
    Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
Back to Top