This is a migrated thread and some comments may be shown as answers.

Scss version connected to kendo version

4 Answers 24 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Dan
Top achievements
Rank 1
Iron
Veteran
Dan asked on 29 Jan 2019, 12:51 PM

Hi,

I saw that the Scss package has a different version than the kendo version. Is there a page where we see the connection between these 2?

What I mean is for example the @progress/kendo-theme-bootstrap@3.2.0 only work with versions starting from Kendo UI R1 2019

Or is it a guaranty that the latest version of the scss file works with any version of kendo?

4 Answers, 1 is accepted

Sort by
0
Preslav
Telerik team
answered on 31 Jan 2019, 11:55 AM
Hi Dan,

The 3.2.0 version of the Kendo Sass Bootstrap theme is compatible with the latest scripts of Kendo UI. However, not all versions of the scrips are working okay with the latest theme.

Having said that, if you have a specific version of the scripts, and you need to know the matching styles version, please, let me know and I will look that for you.

Further, I believe we should have this information outlined in our documentation, thus, I logged this issue:

Regards,
Preslav
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
0
Dan
Top achievements
Rank 1
Iron
Veteran
answered on 31 Jan 2019, 12:13 PM

Hi Preslav,

Right now we are using the kendo version 2018.2.620, and we would like to investigate if we can update to R1 2019.

Could you confirm that the 2018.2.620 should use the @progress/kendo-theme-bootstrap@2.18.0.

0
Accepted
Preslav
Telerik team
answered on 01 Feb 2019, 10:38 AM
Hello Dan,

For the 2018.2.620 version, you should apply the @progress/kendo-theme-bootstrap@2.13.6.

On the other hand, for the R1 2019(2019.1.115), use the @progress/kendo-theme-bootstrap@3.2.0;


Regards,
Preslav
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
0
Dan
Top achievements
Rank 1
Iron
Veteran
answered on 01 Feb 2019, 11:04 AM

Hi Preslav,

Thank you for the information. It seems that my npm package was updating to the latest package and did not realize that the theme was connected to the telerik version.

Tags
General Discussions
Asked by
Dan
Top achievements
Rank 1
Iron
Veteran
Answers by
Preslav
Telerik team
Dan
Top achievements
Rank 1
Iron
Veteran
Share this question
or