Screen not showing when loading different versions of Telerik at the same time.

1 Answer 25 Views
General Discussions
Psyduck
Top achievements
Rank 5
Bronze
Bronze
Bronze
Psyduck asked on 14 Dec 2021, 02:52 AM

Hello.

 

I develop other program modules.

There was a problem using the UI component telerik here.

When executing the main program with each different project, module A and module B are executed.
At this point, the telerik assembly starts loading.

In A, the telerik version is 2021.2.615.45, and B is 2021.3.1025.45. (different versions)
And when I run A and B in the main program, the screen of A is not shown and only B is shown.


That is, my guess is that only the last loaded telerik assembly will be recognized.
Is there any way to solve this?

summary) When loading two versions of telerik in one program, one screen is blank.

Thanks.

1 Answer, 1 is accepted

Sort by
0
Martin Ivanov
Telerik team
answered on 16 Dec 2021, 09:46 AM

Hello KIM,

This sounds like the behavior described in the Missing Controls in the UI article.

Regards,
Martin Ivanov
Progress Telerik

Love the Telerik and Kendo UI products and believe more people should try them? Invite a fellow developer to become a Progress customer and each of you can get a $50 Amazon gift voucher.

Psyduck
Top achievements
Rank 5
Bronze
Bronze
Bronze
commented on 16 Dec 2021, 10:28 AM | edited

Hello.

I checked the link you sent, but this is a completely different problem.
First of all, I am using the xaml dll. And it's not a missing resource either.

Let me give you one more example.

"Paint is the main program." This Paint can be added by creating modules.

I have created project A. This is teleric version 1.1.
And I created a new project B. This is teleric version 1.7.
Modules A and B are attached to the Paint.

Now let's run the Paint program.
Then module A and module B exist.
When A module is selected, the UI is not displayed.
However, module B has a UI displayed.

* When only A module exists in Paint, the UI is displayed normally.

Please check this again and if it does not work, I will open a new support ticket.
Thanks.

Dilyan Traykov
Telerik team
commented on 21 Dec 2021, 09:02 AM

Hello Psyduck,

Thank you for the clarification. Indeed, there seems to be some conflict between the two versions, however, without being able to replicate this at my end, I cannot suggest the exact cause and a possible solution for this.

Would you please find it possible to demonstrate this issue in a small sample project so that we can further assist you? If you do not wish to share your project here, you can open a new support ticket as you already mentioned.
Tags
General Discussions
Asked by
Psyduck
Top achievements
Rank 5
Bronze
Bronze
Bronze
Answers by
Martin Ivanov
Telerik team
Share this question
or