RTB in version 11.3

3 posts, 0 answers
  1. Clifford
    Clifford avatar
    25 posts
    Member since:
    Sep 2013

    Posted 17 Sep 2013 Link to this post

    I have tried to ask a question on another thread, but have not gotten any support, so am generating a new thread. I have seen the example, and have based a project on it, but some features are not the same as the sample so not working. This is at least partially due to the version, but I do not currently have the ability to work on a newer version:

    1) CurrentEditingContext is not the same, being a property with the current context, as opposed to a class with header and footer context properties, and there is no Table context. This also means that there is no possibility of INotifyPropertyChanged working for showing the Table and Header/Footer ribbons. Not sure what the best approach is to deal with showing these menus. Probably had an old version that worked.

    2) The sample code does not contain the implementation for the content of the Insert Merge Field, so not sure what would be considered ideal. In addition, all the Mailings buttons are all disabled so cannot be sure if implementation is working

    I tried to included the project, but changing the extension from zip to gif did not work. Give me a way to send the project and I will.

    Thanks so much for the help.
  2. Petya
    Petya avatar
    989 posts

    Posted 20 Sep 2013 Link to this post


    I am afraid I am having a hard time understanding you. I presume that by version 11.3 you mean Q3 2011, is that correct? Further, can you please elaborate what example you are referring to? We would also appreciate if you explain in details your scenario and the issue with CurrentEditingContext you are facing.

    When it comes to the Mail Merge functionality, the buttons in the predefined UI will be disabled if there is no ItemsSource set to the current document. Furthermore, the drop-down from which insertion is performed is simply bound to the InsertMergeFieldEmptyCommand. Once the items source is set the button is populated. I suggest you review the help article of the feature for more information.

    I hope this helps! I'm looking forward to your reply.

    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. Clifford
    Clifford avatar
    25 posts
    Member since:
    Sep 2013

    Posted 20 Sep 2013 Link to this post

    Figured it out. Need to have instantiate
Back to Top