This is a migrated thread and some comments may be shown as answers.

RowFormatting can't work in Fluent theme

3 Answers 15 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Kun
Top achievements
Rank 2
Kun asked on 19 Dec 2018, 10:40 AM

Hello,

I use rowformatting to change row forecolor in my radgridview. But when I use Fluent theme, the row forecolor changing in rowformatting doesn't work any more.

But it works in some other themes like windows7, windows8, VS2012,Office2007, Desert, Aqua, etc. I've tried change fore color in cellformatting by using Fluent theme, it works. 

Why in Fluent theme, forecolor cannot be changed in rowformatting ?

Thank you

 

 

3 Answers, 1 is accepted

Sort by
0
Dimitar
Telerik team
answered on 20 Dec 2018, 08:34 AM
Hi Kun,

By default, if a particular style is not explicitly set it inherits the value of its parent. This is valid for all elements used in our framework. In this case, the ForeColor of the cell is explicitly set in theme and this is why it is not inheriting the row ForeColor. This depends on the specific theme styles, in this case, the Fluent theme changes the ForeColor of the selected cells and if you are using a single cell selection mode the cells ForeColor is different in one cell only and cannot be iherited from the row.

I hope this will be useful. Let me know if you have additional questions.

Regards,
Dimitar
Progress Telerik
Get quickly onboard and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
0
Kun
Top achievements
Rank 2
answered on 20 Dec 2018, 08:55 AM

Hello Dimitar,

Thank you for your answer.

I use FullRowSelect as SelectionMode of Mastertemplate. But the row forecolor is still override by theme.

Could you tell me which property that I can change for foreColor of the selected cells in the theme style builder ?

I don't need the specific forecolor of selected cells. So I would like to delete this particular setting in the fluent theme by creating my own theme.

Best regards,

 

0
Accepted
Dimitar
Telerik team
answered on 20 Dec 2018, 12:42 PM
Hello Kun,

This can be done by removing the ForeColor setting for all grid cell elements and all states. The attached image shows which setting you need to uncheck.

Should you have any other questions do not hesitate to ask.

Regards,
Dimitar
Progress Telerik
Get quickly onboard and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
GridView
Asked by
Kun
Top achievements
Rank 2
Answers by
Dimitar
Telerik team
Kun
Top achievements
Rank 2
Share this question
or