This is a migrated thread and some comments may be shown as answers.

ReportViewer Undefined - SharePoint 2013

13 Answers 219 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Adam
Top achievements
Rank 1
Adam asked on 03 Jan 2013, 01:16 AM
Hi,

We have recently upgraded to SharePoint 2013 from SharePoint 2010. I have designed a custom ASP solution that uses Telerik Reporting. In SharePoint 2010, this has worked fine, but I am not having any success in 2013.

When I go to generate a report, the ReportViewer screen appears and nothing happens. No "Generating Report, Please Wait" message as there should be.

Currently this issue occurs ONLY in Internet Explorer. The reports generate without issue in Chrome and Firefox.

Using Fiddler and Internet Explorer and Chrome's debugging tools, I have found the following information:

Fiddler:
HTTP/1.1 401 Unauthorized

IE Debugging:
SEC7112: Script from http://xxx/Telerik.ReportViewer.axd?name=Resources.ReportViewer.js&optype=Resource&version=6.2.12.1017 was blocked due to mime type mismatch 

Chrome:
Resource interpreted as Script but transferred with MIME type text/plain: "http://xxx/Telerik.ReportViewer.axd?name=Resources.ReportViewer.js&optype=Resource&version=6.2.12.1017".
SCRIPT5009: 'ReportViewer' is undefined 

I have been through the the help topic located at http://www.telerik.com/community/forums/reporting/telerik-reporting/telerik-reportviewer-missing-in-iis-works-with-dev-webserver.aspx to no avail.

Here are the snippets from my web config file:
<SafeControl Assembly="Telerik.Reporting, Version=6.2.12.1017, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" Namespace="Telerik.Reporting" TypeName="*" Safe="True" />
      <SafeControl Assembly="Telerik.ReportViewer.WebForms, Version=6.2.12.1017, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" Namespace="Telerik.ReportViewer" TypeName="*" Safe="True" />
      <SafeControl Assembly="Telerik.Web.UI, Version=2012.3.1016.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" Namespace="Telerik.Web.UI" TypeName="*" Safe="True" />

<httpHandlers>
  <add path="Telerik.ReportViewer.axd" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=6.2.12.1017, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" verb="*" validate="false" />
  <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2012.3.1016.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" verb="*" validate="false" />
</httpHandlers>

<system.webServer>
  <handlers>
    <add name="Telerik.ReportViewer.axd_*" path="Telerik.ReportViewer.axd" verb="*" type="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=6.2.12.1017, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" preCondition="integratedMode" />
    <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode,runtimeVersionvv2.0." path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2012.3.1016.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" />
  </handlers>
</system.webServer>

 <location path="Telerik.ReportViewer.axd"
   <system.web>
       <authorization>
         <allow users="*" /> 
       </authorization>
   </system.web>
 </location>
 <location path="Telerik.Web.UI.WebResource.axd"
   <system.web>
       <authorization>
         <allow users="*" /> 
       </authorization>
   </system.web>
 </location>

I have also added a MIME type for .axd in IIS and I have tried running Internet Explorer in compatibility mode with no luck.

Any help with this would be appreciated.

Thanks.

13 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 04 Jan 2013, 12:44 PM
Hi Adam,

If the report is loaded correctly in Firefox and Chrome, most likely the problem is with Internet Explorer DOM object. Are you setting height to the viewer in percentage and if so, did you set height to the whole DOM tree (see How do I set 100% height to the Web Report Viewer)? You can very easily check that by starting IE's Developer Tools and inspect the viewer report area height.

Greetings,
Steve
the Telerik team

HAPPY WITH REPORTING? Do you feel that it is fantastic? Or easy to use? Or better than Crystal Reports? Tell the world, and help fellow developers! Write a short review about Telerik Reporting and Telerik Report Designer in Visual Studio Gallery today!

0
Adam
Top achievements
Rank 1
answered on 06 Jan 2013, 09:31 PM
Hi,

I have checked this, but unfortunately makes no difference. Here is my code:

<html xmlns="http://www.w3.org/1999/xhtml" id="html">
<head runat="server">
    <style type="text/css">  
    html#html, body#body, form#form1, div#content
    {
        height: 100%;
    }
    </style>
</head>
<body id="body" style="margin:0px; padding: 0px;">
    <form id="form1" runat="server">             
        <div id="content">
            <telerik:ReportViewer ID="MainReportViewer" runat="server" Height="100%" Width="100%"/>
        </div>
    </form>
</body>
</html>
0
Steve
Telerik team
answered on 07 Jan 2013, 03:58 PM
Hi Adam,

Do you observe the same problem if you set a fixed height in pixels? The problem is not related to the report generation on the server as otherwise it would not be rendered in any browser, so it has to be an issue with the browser itself. Can you provide us with screenshots of the problematic page with IE's Developer Tools opened and showing the height of the report area?

Regards,
Steve
the Telerik team

HAPPY WITH REPORTING? Do you feel that it is fantastic? Or easy to use? Or better than Crystal Reports? Tell the world, and help fellow developers! Write a short review about Telerik Reporting and Telerik Report Designer in Visual Studio Gallery today!

0
Adam
Top achievements
Rank 1
answered on 07 Jan 2013, 09:26 PM
Hi Steve,

Have tried setting a fixed height to the ReportViewer contol with no luck.

Please see the attached screenshot.

Thanks.
0
Accepted
Steve
Telerik team
answered on 10 Jan 2013, 03:19 PM
Hi Adam,

We took the time to setup Sharepoint 2013 server and test on our own. We were able to reproduce the problem and identified the culprit being a fabricated MS response header: nosniff. More information about it can be found in this MSDN article. Removing it from IIS Manager -> HTTP Response Header would resolve the problem and the viewer and report would be loaded properly.

Still, we would make a change on our end to register our scripts with a more appropriate mime type. This fix would be for the Q1 2013 release in February.

Your Telerik points have been updated for bringing this to our attention. Let us know how it goes.

Kind regards,
Steve
the Telerik team

HAPPY WITH REPORTING? Do you feel that it is fantastic? Or easy to use? Or better than Crystal Reports? Tell the world, and help fellow developers! Write a short review about Telerik Reporting and Telerik Report Designer in Visual Studio Gallery today!

0
Adam
Top achievements
Rank 1
answered on 10 Jan 2013, 09:14 PM
Hi Steve,

Thanks for that - that has solved my issue and Reporting is now working as normal.
0
Justin Lee
Top achievements
Rank 1
answered on 27 Mar 2013, 01:22 PM
I am having the same issue.  I would prefer to fix the issue via getting the Q1 2013 version of Reporting -- but before I update my project with the new version, could you confirm that this issue was addressed in the Q1 2013 release?
0
IvanY
Telerik team
answered on 01 Apr 2013, 08:56 AM
Hi Justin,

This has been fixed in the latest internal build (7.0.13.228) and you can download and test it to see how it goes. We apologize for the temporary inconvenience.

Greetings,
IvanY
the Telerik team

Telerik Reporting Q1 2013 available for download with impressive new visualizations. Download today from your account.

0
Ron Boehm
Top achievements
Rank 1
answered on 02 Apr 2013, 05:10 PM
I recently upgraded to .228 and my reports still do not render in IE10
0
IvanY
Telerik team
answered on 05 Apr 2013, 11:12 AM
Hi Ron,

The problem you are having is most probably due the fact that the default browser mode is IE10 Compatibility View and the document mode is IE 7 standards. Reports are working properly with any other combination (in fact they are working even with the forementioned combination, but with some adjustments).

In order to get rid of the issue you will have to add a meta tag to your page that will change the default document mode:
<meta http-equiv="X-UA-Compatible" content="IE=edge" />

Regards,
IvanY
the Telerik team

Have you tried the new visualization options in Telerik Reporting Q1 2013? You can get them from your account.

0
Justin Lee
Top achievements
Rank 1
answered on 24 Apr 2013, 03:51 AM
I have version 7.0.13.220.  I do not see an option to download the internal build .228.  On the side it says:  "If you don't see internal builds, you have to download the lastest official release first"  -- which I believe I have (.220)...

Working with .220, I have tried removing the nosniff header and adding document mode to IE=edge.  Neither of these made a difference.  Also, this only occurs with 3 of our 10 reports.  They work fine in our development and test environments (SP 2013) and also in an SP 2010 environment.  I check our logging, and the data is retrieved -- but the reports just spins forever (never times out or anything)

When I open the reports in chrome, I actually get a 403 FORBIDDEN message in the report area.

Please help!
Justin
0
Justin Lee
Top achievements
Rank 1
answered on 24 Apr 2013, 03:55 AM
Also, I turned on Fiddler and tried to run the report.  It showed a "403 Forbidden" was returned from the following call:
GET /Telerik.ReportViewer.axd?instanceID=86a7467130cf4f9984beda8ea7e357e7&optype=Report&PageIndex=0&RenderID=c8bd47b60508477ebcdb21b070d233ce&RenderingFormat=HTML5Interactive HTTP/1.1
0
Justin Lee
Top achievements
Rank 1
answered on 24 Apr 2013, 04:08 AM
I found a solution that worked for me here:
http://www.telerik.com/community/forums/reporting/telerik-reporting/sharepoint-2010-and-reporting.aspx

Even though it was referring to SharePoint 2010, it applied to my scenario.  I added the nosniff header back in, and changed the meta-tag back to IE=10, and the reports still work.

Thanks,
Justin
Tags
General Discussions
Asked by
Adam
Top achievements
Rank 1
Answers by
Steve
Telerik team
Adam
Top achievements
Rank 1
Justin Lee
Top achievements
Rank 1
IvanY
Telerik team
Ron Boehm
Top achievements
Rank 1
Share this question
or