Reports stop working on production server

4 posts, 0 answers
  1. David Amm
    David Amm avatar
    7 posts
    Member since:
    Mar 2009

    Posted 18 Jul 2013 Link to this post

    When we deploy our application to production the reports work fine for a period of time. Then the reports stop working and we get an "Object not set to a reference" error when trying to load any report. If we redeploy then the error goes away (for a period of time).

    We are using Telerik Reporting v7.1.13.612 in an MVC4 web application running on Windows Server 2008 with IIS7 (Integrated Mode). The bin folder contains the assemblies Telerik.Reporting.dll and Telerik.ReportViewer.WebForms.dll (both v7.1.13.612) and the application pool has Read rights to both files.

    Exception information:
        Exception type: NullReferenceException
        Exception message: Object reference not set to an instance of an object.
       at Telerik.Reporting.Processing.DocumentParametersManager`1.CreateManagers(IReportDocument definition)
       at Telerik.Reporting.Processing.DocumentParametersManager`1..ctor(IReportDocument definition)
       at Telerik.ReportViewer.WebForms.ReportRenderOperation.ProcessReport(ReportSource reportSource, Hashtable deviceInfo, IRenderingContext renderingContext)
       at Telerik.ReportViewer.WebForms.ReportRenderOperation.PerformOperationOverride()
       at Telerik.ReportViewer.WebForms.ReportPageOperation.PerformOperationOverride()
       at Telerik.ReportViewer.WebForms.HandlerOperation.PerformOperation(HttpContext context, ICacheManager cacheManager)
       at Telerik.ReportViewer.WebForms.BasicHandler.ProcessRequest(HttpContext context)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

  2. Victor
    Victor avatar
    2 posts
    Member since:
    May 2016

    Posted 18 May 2016 in reply to David Amm Link to this post

    Hi David!


    I'm with the same problem, did you solved?



  3. Stef
    Stef avatar
    3610 posts

    Posted 20 May 2016 Link to this post

    Hello David,

    Please double-check the deployed configuration and make sure all assemblies are in the Bin folder and the application references them from that Bin folder - Deploying Web Applications.

    In case your web application is running out-proc session state configuration, take a look at the Design Considerations for Out-proc Session State help article

    Also if you use report parameters in code, their actual running values can be obtained from the processing equivalent of the report as illustrated in the Using Report Events help article.

    If you need further help, please open a support ticket and send us a sample project reproducing the issue.


    Have you tried the new visualization options in Telerik Reporting Q2 2013? You can get them from your account.

  4. Victor
    Victor avatar
    2 posts
    Member since:
    May 2016

    Posted 20 May 2016 Link to this post

    Hi everybody!

    Just to update you, I solved the problem. It was caused in my enviroment because a new way to connect database schemas was implemented. I guess your case is different.

Back to Top