This is a migrated thread and some comments may be shown as answers.

Reports Datasource Wizard not working

5 Answers 287 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
David
Top achievements
Rank 1
Veteran
David asked on 27 Jun 2012, 05:58 PM
I noticed that since upgrading to Q2 2012 I have been unable to add new report to my projects.  I even went so far as to remove completely all Telerik components and reinstall them.

Upon deeper inspection it appears to be related to the fact that all of the telerik controls are missing from the "toolbox" of visual studio.  After I added the Telerik.Reporting namespace back to the toolbox the wizard started working again.

While this particular "failure" seems to be report related, why are we seeing all controls vanish from the VS 2010 environment?  I hesitate to blame you folks however its your product that is being "expunged" from the toolbox.  

I have tried all the "reset toolbox" commands.  Things show up then go away again.  I can manually add items to the toolbox however this seems to then require manual changes at the next quarters upgrades.

Even nuking everything does not seem to solve the vanishing telerik toolbox problems.

5 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 28 Jun 2012, 01:11 PM
Hi David,

Thank you for your input. The missing data sources is a known issue and we are currently investigating it. Indeed it is related with the Reporting toolbox, so please make sure you have the Telerik Reporting toolbox items available and if they are missing check out Telerik Reporting Toolbox items are missing KB article. This should fix both of the issues.

If the problem persists, please provide us with the installer log, so we can check it for problems.

Greetings,
Steve
the Telerik team

FREE WEBINAR ON THE NEW REPORT DESIGNER! Join us on Friday, June 29 at 10:00 AM PST for a comprehensive demo of the official version of the standalone Report Designer and find out how easy it is to empower your users with creating, editing and sharing ad-hoc reports. You may even win a free Telerik Ultimate Collection license! Register today >>

0
Negin
Top achievements
Rank 1
answered on 23 Jan 2013, 06:55 AM
Hi,
Apparently i could solve the problem! :)
I use VS 2012 and have Telerik (v. 6.2.12.1025) installed on my computer. i experienced the exact problem and i did what Steve said but it didn't worked! none of the telerik reporting items where in the toolbox and the data source selecting wizard showed no data sources to select! I reset the toolbox and there was no change in toolbox and data source wizard!

****************************************
Do these steps, it worked for me, i hope the same for you ;) (This has been tested in VS 2012 Only!)

1- Go to:  "Tools" ->  "Choose Toolbox Items"
          [Note: you can`t see "Choose Toolbox Items" in "Tools" menu if your VS is set to certain development settings. but you should see it if your VS is set to "General Development Settings", however if you want to reset your VS to "General Development Settings" follow these steps
         1- Go to: "Tools" -> "Import and Export Settings".
         2- Choose "Reset all settings" and click "Next".
         3- Choose the way you want VS to save your current settings. Consider that after VS resets you will loose all of your settings
              so it is recommended that you create a backup of your current settings to export in VS later. Click "Next".
         4- Choose "General Development Settings" and click "Finish".
         5- Restart VS.

2- Choose " .Net Framework Components" tab.
3- Check all items related to Telerik assembly.
[To do this you can sort the items by "Assembly Name"]. Click "OK".
4- Restart VS.


Now you should see all Telerik reporting Items and all available data sources when you open data source selecting wizard for your report! :)

Good luck!
Negin
0
Santa
Top achievements
Rank 1
answered on 06 Feb 2013, 03:22 PM
Thank You.  Your solution solved my problem.  Now I can see all data sources in the new Data Source wizard.  By the way, I am using VS2012.
0
Patrick
Top achievements
Rank 2
answered on 16 Feb 2013, 11:21 PM
The suggested solution (by Negin) didn't work for me: I still can't see any data sources (or add a new one) using Telerik's Report Wizard.

By Check all items related to Telerik assembly

did you mean ALL items, or just the ones related to Telerik reporting?

Also, do I need to have any other Telerik packages installed for Telerik reporting to work, e.g. ASP.net AJAX?

At the moment I just have Kendo UI Complete for MVC and Telerik Reporting installed, because I don't use Telerik ASP.net AJAX.

Thanks


0
Steve
Telerik team
answered on 18 Feb 2013, 12:22 PM
Hi Patrick,

You only need Telerik Reporting installed, it does not depend on any other packages. If none of the proposed solutions in this or other forum threads did not work for you, I would suggest adding required data source component directly from the Toolbox (e.g. if you're binding to SQL database, add SqlDataSource). If you do not see Toolbox items either, please consider repairing Visual Studio and fresh install Telerik Reporting afterwards. If that does not help either, please send the log file requested in the KB article.

Kind regards,
Steve
the Telerik team

HAPPY WITH REPORTING? Do you feel that it is fantastic? Or easy to use? Or better than Crystal Reports? Tell the world, and help fellow developers! Write a short review about Telerik Reporting and Telerik Report Designer in Visual Studio Gallery today!

Tags
General Discussions
Asked by
David
Top achievements
Rank 1
Veteran
Answers by
Steve
Telerik team
Negin
Top achievements
Rank 1
Santa
Top achievements
Rank 1
Patrick
Top achievements
Rank 2
Share this question
or