This is a migrated thread and some comments may be shown as answers.

Reporting webapi report never stops loading

1 Answer 463 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Daniel
Top achievements
Rank 1
Daniel asked on 30 Jan 2019, 03:36 PM

When I run a report via the webapi against a particular webserver, it just gets to where it's loading /api/Reports/clients/123/instances/documents/123/info indefinitely. It returns a status code of 202 Accepted, content has documentReady: false. No error or anything, it just does this indefinitely forever.

 

I'm using the reporting services webapi to run reports with the mvc framework. To do that I have a class which implements IReportResolver, which instantiates a InstanceReportSource and returns that in the Resolve method. I create these InstanceReportSource instances programmatically else where in the same code base, and they work fine in those instances (without the webapi).

I have a nearly identical code base with the exact same reporting implementation on another web server (Windows Server 2012, IIS 7), and there it works fine. It also works fine when I run it in Visual Studio. The environment where it does not work fine is Windows Server 2008 R2, IIS version 6.1. I am curious if upgrading the OS/IIS would fix it, but I can't do that at customer sites where this will be deployed to necessarily.

 

I did find originally when I ran it, it'd crash the application pool. Seemed to be a permission thing because i'm using the TEMP environment variable for file storage, but switching which account the application pool was under fixed it so it wouldn't crash, but this action happens instead.

 

Both webservers are setup nearly identical as far as I can tell, considering they are different versions. Unsure of where to look, if there's some underlying error or something else to be looking at. Any help is appreciated.

1 Answer, 1 is accepted

Sort by
1
Todor
Telerik team
answered on 04 Feb 2019, 01:51 PM
Hello Daniel,

We have previously observed a similar issue with Windows Server 2008 R2. We have related it to the worker threads on IIS.
In general, the requests to the REST Service initiating the report rendering and the actual report rendering are performed in different threads. On older IIS versions this may actually lead to the reporting thread being executed under the windows account running the IIS Worker Process instead of the account configured in the site App Pool. My guess is that the account running the IIS Worker Process does not have adequate permissions for the cache storage.
From the description, I infer that you use File storage. Could you test with another storage type?

The endless Get Document Info request may indicate that the reporting engine has stopped, for example, due to an unhandled Internal Server Error. I suggest attaching a Trace Listener to the Telerik Reporting REST Service project. It may give further insights into the problem.
You may consider opening a support ticket and attaching the generated log for local investigation.

Regards,
Todor
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Marcos
Top achievements
Rank 1
commented on 25 May 2023, 06:09 PM

I'm having a similar issue where my report took some time to render and the viewer is sending Get Document Info request but my problem is that the application pool of the front end is consuming the server memory until crash.. we have about 12 peoples acessing the reports..
Can i disable that Get Document Info request?
Todor
Telerik team
commented on 30 May 2023, 09:40 AM

Hi Marcos,

The request Get Document Info is performed regularly to get the status of the rendered report. There is no option for disabling as there is no other way for informing the viewer when the document is ready. The request doesn't use much server memory and I don't think it may be causing the memory issue. The memory usage may be from the report processing and rendering.

Did you attach a Trace Listener to the Telerik Reporting REST Service project? I hope it will elaborate on the server-side problem if there is any.

Tags
General Discussions
Asked by
Daniel
Top achievements
Rank 1
Answers by
Todor
Telerik team
Share this question
or