This is a migrated thread and some comments may be shown as answers.

Report Viewer Print not working

4 Answers 229 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Anuj
Top achievements
Rank 1
Anuj asked on 19 Apr 2013, 11:51 AM
Hi,

We are facing issues with report viewer printing. I tried telerik's online demo on my machine the following browsers.
Chrome, FireFox, Safari, IE 10. all working great except Safari.

I have downloaded and upgraded my solution with Telerik_Reporting_Q1_2013_build_7.0.13.220 however report viewer print is not working. It neither open print dialog nor download the PDF on print click for FireFox, Safari, IE 10 where as works great with Chrome.

as the next step I have download CSharp report examples "Telerik_Reporting_Q1_2013_build_7.0.13.412_TRIAL" one of your internal build. When i run the solution result is same, print is not working. It neither open print dialog nor download the PDF on print click for FireFox, Safari, IE 10 where as works great with Chrome.

I have Adobe reader version 11 installed on my machine.

Please advice.

Thanks,
Anuj


 

4 Answers, 1 is accepted

Sort by
0
Stef
Telerik team
answered on 19 Apr 2013, 04:58 PM
Hello Anuj,

In your other forum thread and support ticket we have discussed problems with Adobe Reader 11.0.02 and printing under IE9. Please let us know the requested details about the settings from the mentioned help article and which Telerik Reporting versions and browsers fail to print for you.

Our tests does not point problems with any of the mentioned versions or browsers.

Greetings,
Stef
the Telerik team

Have you tried the new visualization options in Telerik Reporting Q1 2013? You can get them from your account.

0
Anuj
Top achievements
Rank 1
answered on 25 Apr 2013, 12:18 PM
Hi Stef,

 You are correct as I mentioned your online demo works great except safari. However In my project its not printing at all.

Win 7 machine
1) IE 10 - Adobe PDF reader 11.0.01.36 - Print not working - On the print click its seems request goes back (browser blinks) but retruns back with nothing.
2) FireFox 12.0 - Adobe PDF reader 11.0.01.36 - Print not working
3) Safari 5.1.7 - no Adobe plug in - Print not working - It should download the PDF if plugin not found.
4) Chrome - no Adobe plug in - Working flawlessly may be because It uses chrome's plug in for print. 

As I already mentioned I am using "Telerik_Reporting_Q1_2013_build_7.0.13.412_TRIAL".

Addition to the same: In my project we are creating reports and subreports programmatically using C#. and code was built using reporting version 5.1. can this be a problem?

Let me know If you need more Info.

~Anuj
0
Anuj
Top achievements
Rank 1
answered on 25 Apr 2013, 04:22 PM
One more point on the above post:

When I hit print button, button get disabled and after a postback gets enabled again (but no download). I checked fiddler and It says that response I got is a PDF.
0
Stef
Telerik team
answered on 30 Apr 2013, 11:03 AM
Hello Anuj,

As we stated before the issue is not reproducible at our side with the mentioned Adobe Reader version, so if you use assembly qualified names with exact versions, it may cause the printing issues. Please download Telerik Reporting SP1 (from Products & Subscription - Trial Downloads in case you use this account), upgrade all report libraries, the Silverlight and web applications, so versions are the same and try again. 

If the issue still persists, reopen ticket 682683 and send us a runnable sample project, where the problem is reproducible.

Kind regards,
Stef
the Telerik team

Have you tried the new visualization options in Telerik Reporting Q1 2013? You can get them from your account.

Tags
General Discussions
Asked by
Anuj
Top achievements
Rank 1
Answers by
Stef
Telerik team
Anuj
Top achievements
Rank 1
Share this question
or