This is a migrated thread and some comments may be shown as answers.

Report viewer appear with missing images and controls

2 Answers 134 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Felice
Top achievements
Rank 1
Felice asked on 16 Mar 2014, 04:12 PM
I have this weird problem. Please see the attached picture. Th report viewer appears completely messy on the server but they are 100% fine on my local.
What could be the problem?

2 Answers, 1 is accepted

Sort by
0
Felice
Top achievements
Rank 1
answered on 16 Mar 2014, 04:17 PM
hops...forgot to say that is Q1 2014,  ASP and the viewer is the Telerik

<%@ Register Assembly="Microsoft.ReportViewer.WebForms, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" Namespace="Microsoft.Reporting.WebForms" TagPrefix="rsweb" %>
 
<%@ Register Assembly="Telerik.ReportViewer.WebForms, Version=8.0.14.225, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" Namespace="Telerik.ReportViewer.WebForms" TagPrefix="telerik" %>
0
Peter
Telerik team
answered on 17 Mar 2014, 03:28 PM
Hello Felice,

Generally the missing images and controls indicate misconfiguration of the report viewer HttpHandler. As reference check out our demos configuration file (web.config). The demos source code came with your Telerik Reporting installation. Additionally you may find useful the following help resources:
How to: Add report viewer to a web page help article
The styles of the web report viewer's toolbar are messed up KB article

Regards,
Peter
Telerik
 

DevCraft Q1'14 is here! Watch the online conference to see how this release solves your top-5 .NET challenges. Watch on demand now.

 
Tags
General Discussions
Asked by
Felice
Top achievements
Rank 1
Answers by
Felice
Top achievements
Rank 1
Peter
Telerik team
Share this question
or