This is a migrated thread and some comments may be shown as answers.

Report height issue

18 Answers 551 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Mike
Top achievements
Rank 1
Mike asked on 13 Feb 2009, 04:37 PM
I have report with the following tag:
 <telerik:ReportViewer ID="ReportViewer1" Width="100%" Height="525"  runat="server" /> 

The report is taller than the report window (525) drawn and vertical scrolling goes behind the report window. 

How do I get the report to fit the size assigned in the ReportViewer tag?

18 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 16 Feb 2009, 12:54 PM
Hi Mike,

I'm not quite sure what you mean by "vertical scrolling goes behind the report window" - it is not possible to use the scroll or?
Anyway, in order to show the whole page in the ReportViewer, you can set ZoomMode="FullPage".

Regards,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Mike
Top achievements
Rank 1
answered on 16 Feb 2009, 01:22 PM
Steve,

I mean that the report viewer window is smaller then the report.  The scrollbar goes behind the window for the report.

I will try the zoom full.
Mike
0
Mike
Top achievements
Rank 1
answered on 20 Feb 2009, 09:11 PM
Steve,

I want to send you a screenshot of the report and the height issue.  What is the best way to send you the image?

Thanks!
0
Mark
Top achievements
Rank 1
answered on 21 Feb 2009, 03:51 PM
I'm having the same problem here, and still no resolution after playing around with it for quite some time.

I can reproduce this problem very easily just by dropping the viewer into a table, like this:

<table cellpadding="0" cellspacing="0" style="height: 100%; width: 100%"
        <tr> 
            <td> 
                <telerik:ReportViewer ID="ReportViewer1" runat="server" Height="500px" Width="100%" Skin="Office2007"
                </telerik:ReportViewer> 
            </td> 
        </tr> 
    </table> 

Now if I scroll the report down a bit, the bottom will be cut off. The problem is worsened if there are visible report parameters.

I'm using the latest public build available at the time of this writing (2008.3 1402).
0
Steve
Telerik team
answered on 23 Feb 2009, 08:55 AM
Hi guys,

I'm not sure I understand what the problem is and what the end result should be. We definitely need more info:
  • used browser and its version. Does this happen on other browsers as well?
  • screenshot/report that shows the problem at hand
  • should the vertical scroller disappear?
Please open a support ticket and attach the files/images there and once we review it, we would be able to provide you with more info. Meanwhile, if this is all happening in IE,  please take a look at the bottom of this help article, that elaborates on setting 100% height of the report viewer.
Sincerely yours,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Mike
Top achievements
Rank 1
answered on 23 Feb 2009, 01:36 PM
Steve,

The first image in the link you sent us explains my point.  As you can see there are two scroll bars.  The inside scroll bar is what I want to get rid of and use only paging.

Mike
0
Steve
Telerik team
answered on 24 Feb 2009, 02:56 PM
Hi guys,

@Mike: for the time being, the report viewer cannot set its size according to the displayed report. The workaround would be to set its height to a value, where there would not be a need for scrollbar or use the ZoomMode property.
@Mark: you can either remove the doctype of the page or apply height to the whole DOM tree i.e.:

 <style type="text/css">  
      html#html, body#body, form#form1
      {
       height: 100%;
      }
</style>
 <table width="100%" style="height: 100%;">
            <tr>
                <td>
                    <telerik:ReportViewer ID="ReportViewer1" runat="server" Width="100%" Height="470px">
                    </telerik:ReportViewer>
                </td>
            </tr>
        </table>


Kind regards,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Mike
Top achievements
Rank 1
answered on 02 Mar 2009, 03:34 PM
Steve,

It didn't help, I have a screenshot for you.  How can I send it to you so you can see what's happening?
0
U4
Top achievements
Rank 1
answered on 03 Mar 2009, 03:58 AM
Just encountered the same problem wherein my report is larger than the report viewer.

I tried the work around also with no avail:

@Mike: for the time being, the report viewer cannot set its size according to the displayed report. The workaround would be to set its height to a value, where there would not be a need for scrollbar or use the ZoomMode property.

The report viewer displays a scroll bar instead of automatically setting it to paging, I tried the export to PDF and its working.

Any other work around for this issue?

Thanks

0
Steve
Telerik team
answered on 03 Mar 2009, 02:32 PM
Hi guys,

@Mike: please open a support ticket and send us a sample page exhibiting the problematic behavior. We would review it and modify it accordingly.
@Pss: Are you saying that altering the ZoomMode property has no effect? We're not sure what you mean by "automatically setting it to paging" and what this has to do with the pdf export. Please elaborate or better of provide a web project showing the problem at hand.

Sincerely yours,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
rick
Top achievements
Rank 1
answered on 13 Apr 2009, 10:58 AM
Was this issue resolved? I'm having the same problem where in IE 7, It doesn't allow me to scroll to bottom of the report. It works fine in FireFox
0
Steve
Telerik team
answered on 13 Apr 2009, 11:22 AM
Hi Rick,

Is the ReportViewer set to 100% height? If so, please use the suggestion for applying height to the whole DOM tree as shown in one of the answers above. If this is not the case, a sample project would be appreciated.

Best wishes,
Steve
the Telerik team

Check out Telerik Trainer , the state of the art learning tool for Telerik products.
0
rick
Top achievements
Rank 1
answered on 13 Apr 2009, 11:47 AM
I'm going to open a support ticket and attach a sample project.
0
Rupali
Top achievements
Rank 1
answered on 26 Jun 2009, 06:48 AM
I am also having same issue as of Mark.
In the report, if I scroll down the bottom will be cut off.
Please let me know if this issue is resolved.

Thanks and looking forward,
Rupali
Vana solutions


0
Steve
Telerik team
answered on 26 Jun 2009, 09:03 AM
Hi Rupali,

If you follow the recommendations from our previous posts in this thread, you should resolve this easily. Both Mike's and Rick's problems we identified in the support tickets were due to not setting height to all "parent" elements. Nevertheless we have recently made a breakthrough, and in Q2 2009 (expected next week), this should be working out of the box. Note however that this is NOT a bug, and it is still highly recommended to set height/width to all DOM elements in order to avoid leaving the layout of your page to the mercy of the browser.

All the best,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Rupali
Top achievements
Rank 1
answered on 26 Jun 2009, 10:59 AM
Hello steave,

I have set height of all parent elements to 100%. Still the issue persists.
Here is how I set height of all elements to 100% :-
 <style type="text/css">           
        html#html, body#body, form#form1, div#content, center#center
        {   
            border: 0px solid black;
            padding: 0px;
            margin: 0px;
            height: 100%;
            overflow:hidden;
        }
    </style>


Although If I remove overflow:hidden, I can see full report including footer.
I really need to have only one scrollbar (either browser or report viewer).
Do you know if there is any fix for this kind of scenario?

Thanks and looking forward,
Rupali
Vana solutions
0
MrMaestro
Top achievements
Rank 1
answered on 13 Apr 2010, 04:09 PM
I'm aware of the hack-factor of this solution, but it did the trick for me:

I'm using jquery here to add a negative margin to the ReportArea Table. This way it will show the 13 pixels which where falling off (the make everyting 100% height solution did not work for me).

 

 

        <script type="text/javascript">  
              
            //fix height problem with reportviewer 
            $(function() {  
                $('#<%=ReportViewer1.ClientID %>_ReportArea_ReportArea').css("marginTop"" -13px");  
            });  
        </script> 

 

0
Mike
Top achievements
Rank 1
answered on 13 Apr 2010, 04:20 PM
I gave up on the report, it takes too long to process and line everything up.  I just use the grids now and export to excel or pdf if they want to print!
Tags
General Discussions
Asked by
Mike
Top achievements
Rank 1
Answers by
Steve
Telerik team
Mike
Top achievements
Rank 1
Mark
Top achievements
Rank 1
U4
Top achievements
Rank 1
rick
Top achievements
Rank 1
Rupali
Top achievements
Rank 1
MrMaestro
Top achievements
Rank 1
Share this question
or