Rendering issues in Report Viewer - HTML 5

5 posts, 0 answers
  1. Harsimrat
    Harsimrat avatar
    14 posts
    Member since:
    Nov 2014

    Posted 08 May Link to this post

    We are using HTML 5 Report Viewer and sometimes the report doesn't render correctly (please see attached). If we press the refresh button in the viewer again, the report cleans up.

    This happens intermittently and not all the time.

  2. Todor
    Admin
    Todor avatar
    333 posts

    Posted 13 May Link to this post

    Hi Harsimrat,

    From the screenshot and the description of the problem it seems like the CSS styles of the Html5 Report Viewer sometimes load successfully and sometimes fail to load.
    Does the issue appear in 'CONTINUOUS_SCROLL' pageMode only (check Report Viewer Initialization Options) or also with 'SINGLE_PAGE' ? We have already fixed a similar bug and the fix would be released in our upcoming Release R2 2019 scheduled for May 15th 2019.

    Could you specify the exact scenario/steps that lead to the issue? We would need to reproduce it locally and investigate further.
    Consider sending us a runnable project that demonstrates the problem.

    Regards,
    Todor
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Harsimrat
    Harsimrat avatar
    14 posts
    Member since:
    Nov 2014

    Posted 13 May in reply to Todor Link to this post

    Hello Todor,

    Thank you for your reply. We are using CONTINUOUS_SCROLL (Default) and it's behavior is very strange.

    Once the CSS breaks, you scroll down the page and scroll back up, the Report renders correctly and doesn't need refresh of the page.

    It's very hard to replicate this behavior, as it doesn't break all the time.

    Harsimrat

  4. Harsimrat
    Harsimrat avatar
    14 posts
    Member since:
    Nov 2014

    Posted 13 May in reply to Harsimrat Link to this post

    One more thing to add, scrolling up and down only works when you have multiple pages. If report is on single page, scrolling does't help and the CSS stays broken.
  5. Todor
    Admin
    Todor avatar
    333 posts

    Posted 16 May Link to this post

    Hi Harsimrat,

    From the additional details it seems that the issue is the one that is already fixed in our latest release (R2 2019) - Missing report styles when the Telerik Report Viewer is recreated.
    You may upgrade to check whether this will solve the problem.

    Regards,
    Todor
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top