This is a migrated thread and some comments may be shown as answers.

RadMaskedNumericInput - SelectAll() not working when value = 0

3 Answers 21 Views
MaskedInput (Numeric, DateTime, Text, Currency)
This is a migrated thread and some comments may be shown as answers.
Hans
Top achievements
Rank 1
Veteran
Hans asked on 18 Jul 2019, 02:05 PM

Hi,

I'm using the RadMaskedNumericInput with Mask="#6.2".  SelectAll() is called when the control gets the focus.  This works fine as long as the value of the binded property is not zero.  In this case, only the decimals and decimal point get selected, but not the zero digit before the decimal point (see attachment), which is very annoying behavior for the end user.

Regards,
Hans

3 Answers, 1 is accepted

Sort by
0
Hans
Top achievements
Rank 1
Veteran
answered on 18 Jul 2019, 03:14 PM
This time with attachment ;-)
0
Accepted
Vladimir Stoyanov
Telerik team
answered on 23 Jul 2019, 08:12 AM
Hello Hans,

Thank you for the provided picture. 

Can you try setting the SelectionOnFocus property of the control? You can set it to SelectAll in order to achieve what you are going for: 
<telerik:RadMaskedNumericInput SelectionOnFocus="SelectAll" />

This way you would not have to manually call the SelectAll method. Please, give this a try and let me know how it goes.

Regards,
Vladimir Stoyanov
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
0
Hans
Top achievements
Rank 1
Veteran
answered on 29 Jul 2019, 08:04 AM

Hi Vladimir,

that's it !  Thanks !

Regards,

Hans

Tags
MaskedInput (Numeric, DateTime, Text, Currency)
Asked by
Hans
Top achievements
Rank 1
Veteran
Answers by
Hans
Top achievements
Rank 1
Veteran
Vladimir Stoyanov
Telerik team
Share this question
or