RadEditor Image Manager Upload Button and others Disabled

11 posts, 0 answers
  1. Evelyne Schreiner
    Evelyne Schreiner avatar
    20 posts
    Member since:
    Sep 2009

    Posted 01 Mar 2012 Link to this post

    Hello,

    I've seen many threads about this problem but none of the solutions provided seems to be working for me.

    I'm using radEditor and the upload button (and the others) are disabled in the Image Manager on the production server. It's, working fine on my development server though.

    It's the first time I've got this problem and I've used the editor in other applications.

    To make sure the problem is not due to some Javascript or other codes, I've created a simple .aspx page (not secured or anything) with just this HTML and code-behind :

     

    <%@ Page Language="VB" AutoEventWireup="false" CodeFile="editor.aspx.vb" Inherits="editor" %>
     
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
     
    <head runat="server">
        <title>Test</title>
    </head>
    <body>
        <form id="form1" runat="server">
        <div>
            <telerik:RadScriptManager runat="server" ID="RadScriptManager1"></telerik:RadScriptManager>
             <telerik:RadEditor ID="fTest" Width="960px" ToolsFile="~/editor/ToolsFile.xml" ValidationGroup="MyValidationGroup" Runat="server">
                <Tools>
                    <telerik:EditorToolGroup Tag="FileManagers">
                        <telerik:EditorTool Name="ImageManager" />
                    </telerik:EditorToolGroup>
                </Tools>
            </telerik:RadEditor>
        </div>
        </form>
    </body>
    </html>

    Dim nomRepGeneral As String = "~/uploaded/test"
    fTest.ImageManager.ViewPaths = New String() {nomRepGeneral}
    fTest.ImageManager.UploadPaths = New String() {nomRepGeneral}
    fTest.ImageManager.DeletePaths = New String() {nomRepGeneral}


    I've used the test code to make sure the rights are set correctly on the folder (here).

    Any idea ?

    Thank you

  2. Rumen
    Admin
    Rumen avatar
    14322 posts

    Posted 02 Mar 2012 Link to this post

    Hello,

    Could you please test the attached project and let me know if the problem still persists?
    For your convenience I have attached a video demonstrating my test: http://screencast.com/t/0kqU0noLu0.

    Regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Evelyne Schreiner
    Evelyne Schreiner avatar
    20 posts
    Member since:
    Sep 2009

    Posted 05 Mar 2012 Link to this post

    Thank you Rumen.

    I've tested the project and it also doesn't work.

    I've made more tests on my dev server and I think, I've found something which might be a clue. The error happens when it's a sub-site and the root website is running under .net 3.5.

    Maybe something in the web.config? (I've used <location path="." inheritInChildApplications="false"> in the root website)

     

  4. Evelyne Schreiner
    Evelyne Schreiner avatar
    20 posts
    Member since:
    Sep 2009

    Posted 07 Mar 2012 Link to this post

    Any suggestion about this (see above) ?

    Is there something to change in the web.config ? Is it possible to use RadEditor on a sub-site running under .net 4 and root website running on .net 3.5 ?

    Thank you,
  5. Rumen
    Admin
    Rumen avatar
    14322 posts

    Posted 07 Mar 2012 Link to this post

    Hello,

    Did you test the provided project standalone without including it in a .NET 3.5 based website? Does the image manager work when the project is configured as a standalone .NET 4.0 web site in IIS?

    Could you please also provide the web.config file of the root .NET 3.5 site?

    Best regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. Evelyne Schreiner
    Evelyne Schreiner avatar
    20 posts
    Member since:
    Sep 2009

    Posted 09 Mar 2012 Link to this post

    I've tested the project standalone:

    As a root website (4.0):
    The uplodad works perfectly.

    As a subsite (4.0), rootsite running in 3.5 :
    The uplodad buttons and others are disabled and I cannot see the files in the "uploaded" folder.

    The web.config of the 3.5 root site :

    <?xml version="1.0"?>
    <configuration>
        <system.web>
            <compilation defaultLanguage="vb" debug="true">
            </compilation>
            <customErrors mode="Off"/>
            <authentication mode="Windows"/>
            <authorization>
                <allow users="*"/>
            </authorization>
            <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
            <xhtmlConformance mode="Legacy"/>
            <pages>
                <namespaces>
                    <add namespace="Microsoft.VisualBasic"/>
                </namespaces>
            </pages>
        </system.web>
    </configuration>

    Thank you
  7. Rumen
    Admin
    Rumen avatar
    14322 posts

    Posted 13 Mar 2012 Link to this post

    Hello,

    Thank you for the additional information.

    I tried to recreate the reported scenario but without success as you can see in the following video: http://screencast.com/t/M7k5ILEX.
    I just added allowOverride="false" in the root site's web.config file:

    <?xml version="1.0"?>
    <configuration>
      <location path="." allowOverride="false" inheritInChildApplications="false">
        <system.web>
          <compilation defaultLanguage="vb" debug="true">
          </compilation>
          <customErrors mode="Off"/>
          <authentication mode="Windows"/>
          <authorization>
            <allow users="*"/>
          </authorization>
          <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
          <xhtmlConformance mode="Legacy"/>
          <pages>
            <namespaces>
              <add namespace="Microsoft.VisualBasic"/>
            </namespaces>
          </pages>
        </system.web>
      </location>
    </configuration>

    If you unable to fix the problem at your side, my suggestion is to not nest the RadEditor's .NET 4.0 project in .NET 3.5 projects.

    Kind regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  8. Evelyne Schreiner
    Evelyne Schreiner avatar
    20 posts
    Member since:
    Sep 2009

    Posted 13 Mar 2012 Link to this post

    Hello Rumen,

    I added allowOverride="false" in the root site's web.config file and... it's working fine !!

    Thank you very much for your help !

  9. Yogesh
    Yogesh avatar
    1 posts
    Member since:
    Nov 2012

    Posted 14 Mar 2013 Link to this post

    Hello Rumen,

    I am experiencing somewhat same problem as Evelyne. I am using RadEditor in dotnetnuke. It has Image Upload and Template Manager tabs in it and they are working fine in all browsers except IE. What happens in IE is once the open the website for the first time in IE(default document mode changes to quirks mode for my website) and open the page which has RadEditor. When I click on Image Upload tab, Image Manager tab opens but all tabs on it are disabled. If I change the document mode from QuirkMode to IE 7 standard then it works fine. And if the change the document mode back to quirksMode then also it works fine. It just doesn't work for the very first time.

    I pro-grammatically changed the document mode to IE 7 standard for the page with RadEditor but it still doesn't work for the first time.

    Any help is greatly appreciated.
  10. Rumen
    Admin
    Rumen avatar
    14322 posts

    Posted 14 Mar 2013 Link to this post

    Hi,

    The Professional DNN provider of RadEditor, which is shipped with the DNN 5+ installations, is implemented by DotNetNuke and it is not supported by Telerik.

    My suggestion is to post the question about how to configure RadEditor in the DNN forums. For example in this one: Taming (customizing) The new Telerik RadEditor.

    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  11. venkat
    venkat avatar
    3 posts
    Member since:
    May 2013

    Posted 21 Jan 2014 Link to this post

    Hi Schreiner

    I also have Same Problem...... I solved this problem by my self.
    i read almost all articles finally i find the solution analyzing them.
    i.e We need to add  AllowScripts="True" in radeditor Markup.
    Example:
    <telerik:RadEditor ID="BodyText" SkinID="BasicSetOfTools" runat="server" Height="400" DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd" 
                            Width="860px" EnableResize="true" AllowScripts="True">
    <ImageManager UploadPaths="~/img" ViewPaths="~/img" MaxUploadFileSize="10240000"  SearchPatterns="*.gif, *.jpg, *.jpe, *.jpeg, *.tiff, *.tif,*.bmp"/>
    </telerik:RadEditor>

    **Very Important
    don't forgot to add handler file in web.config file
    <httpHandlers>
                <add path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
                <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false"/>
                <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>
                <add path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false"/>
            </httpHandlers>
    and
    <system.webServer>
        <!--<modules runAllManagedModulesForAllRequests="true"/>-->
        <validation validateIntegratedModeConfiguration="false"/>
        <handlers>
            <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.aspx" type="Telerik.Web.UI.DialogHandler"/>
            <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler"/>
            <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource"/>
            <add name="Telerik_Web_UI_DialogHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler"/>
        </handlers>
    </system.webServer>

    This Code Solve My Problem.
    Now I can Add Image through Image Manager.
     
    Thanks and Regard
    Venkat
    Application Programer
Back to Top