[Question][Report Designer Standalone]: Adding a 2nd Parameter gives me "Cannot Evaluate Parameter"

1 Answer 99 Views
DataSource SQL DataSources Report Designer (standalone) Report Parameters
Austin
Top achievements
Rank 2
Iron
Iron
Iron
Austin asked on 13 Feb 2023, 10:02 PM

Good Afternoon Telerik Forums,

I have a MainData (SQLDataSource) a (Tech1DataSource) and a (Tech2DataSource).

 

I have 4 parameters currently. From Date(start date), To Date(end date), Tech1IDParameter, Tech2IDParameter.

If I remove Tech2IDParameter- the report loads fine without an error. However, when I add in Tech2IDParameter (pointing to Tech2DataSource) I get the error below.

 

Tech1IDParameter and Tech2IDParameter are virtually identical in the settings and parameter fields except for what they query. Any help would be greatly appreciated! Please see the error below.

 

Unable to get report parameters.
An error has occurred.
Cannot evaluate parameter 'Tech2IDParameter'.

1 Answer, 1 is accepted

Sort by
0
Accepted
Austin
Top achievements
Rank 2
Iron
Iron
Iron
answered on 14 Feb 2023, 06:56 PM | edited on 14 Feb 2023, 06:56 PM

Correction, I solved this issue. 

 

I was calling a non-existent data column on the parameter for "ValueMember" that wasn't located in my 2nd SQL source.

Tags
DataSource SQL DataSources Report Designer (standalone) Report Parameters
Asked by
Austin
Top achievements
Rank 2
Iron
Iron
Iron
Answers by
Austin
Top achievements
Rank 2
Iron
Iron
Iron
Share this question
or