This is a migrated thread and some comments may be shown as answers.

Q1 2012 and Lightswitch

3 Answers 60 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Devin
Top achievements
Rank 1
Devin asked on 24 Feb 2012, 10:18 PM
I've got a Lightswitch app that consumes a report from our IIS hosted Telerik reporting WCF service, and it was working fine on 2011 Q3. I'm trying to update it to Q1 2012 and now I'm getting the following error:

The property 'Theme' does not exist on the type 'ReportViewer' in the XML namespace 'http://schemas.telerik.com/2008/xaml/presentation'.

What causes this?

Thanks

3 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 28 Feb 2012, 05:22 PM
Hello Devin,

We've not encountered such problem so far. Setting a theme for the Silverlight report viewer is done through the telerikControls:StyleManager.Theme, so check if this is how you do it. For more info refer to Setting a Theme help article.

Regards,
Steve
the Telerik team
NEW in Q1'12: Telerik Report Designer (Beta) for ad-hoc report creation. Download as part of Telerik Reporting Q1 2012. For questions and feedback, use the new Telerik Report Designer Forum.
0
Devin
Top achievements
Rank 1
answered on 28 Feb 2012, 05:25 PM
Indeed, that's how I was doing it. The only change I made was to replace the Q3 2011 assemblies for the Q1 2012 ones.
0
Steve
Telerik team
answered on 28 Feb 2012, 05:26 PM
Hi Devin,

Open a support ticket and attach a small proof of concept sample that works correctly with the Q3 release but fails with Q1. We would review it locally and advise you accordingly.

Greetings,
Steve
the Telerik team
NEW in Q1'12: Telerik Report Designer (Beta) for ad-hoc report creation. Download as part of Telerik Reporting Q1 2012. For questions and feedback, use the new Telerik Report Designer Forum.
Tags
General Discussions
Asked by
Devin
Top achievements
Rank 1
Answers by
Steve
Telerik team
Devin
Top achievements
Rank 1
Share this question
or