This is a migrated thread and some comments may be shown as answers.

Property Builder docikg windows disappeared

4 Answers 36 Views
GridView
This is a migrated thread and some comments may be shown as answers.
dmajkic
Top achievements
Rank 2
dmajkic asked on 06 Jun 2008, 07:36 AM
Hi.

I opened radGridView property builder and clicked on [x] to turn off docking windows. But now docking windows are not shown at all in property builder, and I can't find a way to reset property builder.

How can I restore closed docking windows in property builder?

I am working with RadWinControls 2008 SP1.

4 Answers, 1 is accepted

Sort by
0
Accepted
Nikolay
Telerik team
answered on 06 Jun 2008, 09:35 AM

Hello dmajkic,

In versions, prior to Q1 2008 SP1, the RadGridView Property Builder had close buttons by which you could hide the docking windows. However, in Q1 2008 SP1, these buttons are removed and if you have the Q1 2008 SP1 version installed, you should not be able to see them.

Generally, concerning the issue with the hidden docking windows, there are two ways to workaround it:

  1. Try to close and open again the property builder. In the majority of cases, this should return your docking windows as floating.
  2. When you are altering the settings of the Property Builder's docking (i.e closing a docking window), these settings are serialized in the RadGridViewPropertyBuilderDockLayout.cfg (or RadGridView_Docking.cfg, depending on the suite's version) file to keep the same layout of the Property Builder. If step 1 does not help you, please try deleting these files and then try to open the Property Builder again. The default files' location is: C:\Documents and Settings\All users\Application Data\Microsoft Corporation\[Visual Studio version]\[Visual Studio version number]\

I hope this helps. If you have additional questions, do not hesitate to contact me.

All the best,

Nikolay
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
dmajkic
Top achievements
Rank 2
answered on 06 Jun 2008, 10:05 AM
Deleting RadGridViewPropertyBuilderDockLayout.cfg  did it.

Thank you.
0
dmajkic
Top achievements
Rank 2
answered on 06 Jun 2008, 02:12 PM
In versions, prior to Q1 2008 SP1, the RadGridView Property Builder had close buttons by which you could hide the docking windows. However, in Q1 2008 SP1, these buttons are removed and if you have the Q1 2008 SP1 version installed, you should not be able to see them.

If you undock, [x] button is displayed, and then you can close floating forms. Also, context menu has Hide item. But there is no place to show closed windows from builder. You can restore them by deleting cfg file.
0
Nikolay
Telerik team
answered on 09 Jun 2008, 08:48 AM
Hi dmajkic,

Thank you for the feedback.

I agree these approaches for closing the docking windows exist. They will be removed in one of our future releases.

If you have additional questions, do not hesitate to contact me.

Kind regards,
Nikolay
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
GridView
Asked by
dmajkic
Top achievements
Rank 2
Answers by
Nikolay
Telerik team
dmajkic
Top achievements
Rank 2
Share this question
or