This is a migrated thread and some comments may be shown as answers.

Problems with special characters "ç, ã, etc..."

1 Answer 172 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Leandro
Top achievements
Rank 1
Leandro asked on 05 Jan 2011, 02:42 PM
Hi,

My application show weird characters in a TextBox with expression when the value contains special Brazilian characters like "ç, ã, etc...".

Ex.: Empresa: Homologa??o

I'm using mixed pages from ASP 3.0 and ASP.Net 4.0.

In attached file I send two samples, first sample (correct.png) is a 100% ASP.Net 4.0 page and the characters shows correct;
In second sample (wrong.png) the pages are 50% in ASP 3.0 and 50% in ASP.Net 4.0 and the characters don't show correct.
        This pages are a frameset. The Top page "Monitor de Operações" developed in ASP 3.0, the Middle page is developed in ASP.Net 4.0 with Telerik Reports and the Bottom page Controls (Listar, Enviar, etc...) is developed with ASP 3.0.

Sorry, but my English is no good!

Thx,

Leandro 

1 Answer, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 07 Jan 2011, 04:21 PM
Hi Leandro,

As we see from the Wrong screenshot you've attached, the characters do not show in some occasions, but show properly on other (e.g. Descricao). So in this line of thoughts, this might be related to the used fonts for those TextBoxes - can you verify they are available on the machine you're opening the report on?
Additionally we're not clear on the 50% in ASP 3.0 and 50% in ASP.Net 4.0 part - a project can target only a single framework. Can you elaborate on that part?

All the best,
Steve
the Telerik team
Get started with Telerik Reporting with numerous videos and detailed documentation.
Tags
General Discussions
Asked by
Leandro
Top achievements
Rank 1
Answers by
Steve
Telerik team
Share this question
or