This is a migrated thread and some comments may be shown as answers.

Problems at windows XP‏

4 Answers 56 Views
Window
This is a migrated thread and some comments may be shown as answers.
JEONG-YUN
Top achievements
Rank 1
JEONG-YUN asked on 15 Mar 2013, 02:05 AM
Hi

I'm the one of user who bought telerik and using my project, WPF.

I'd like to ask about something for that Windows XP shows me some error messages using this component such as

"not ui thread. telerik.windows.controls.stylemanager.theme"
"telerik.Radprogressbar~~~"

Does anybody have any solutions about this problem?

I've been seen few problems at this forum but coudn't find any answers at all.

or do I have to do something to XP computers like change setup or reinstall or etc??

Please give me any advice in this case.

Really appreciate for your help~~~~

4 Answers, 1 is accepted

Sort by
0
Vladislav
Telerik team
answered on 19 Mar 2013, 01:28 PM
Hi JEONG-YUN PARK,

We have receive such reports in the past but unfortunately we wasn't able to reproduce them at our side.
Is it possible to send us your project (or just the relevant part of it) in order to further investigate this issue?  
Also can you please specify the exact version of our controls you are using.

Thank you in advance.

All the best,
Vladislav
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
Xiaroun
Top achievements
Rank 1
answered on 10 Mar 2019, 05:16 AM

The problem is due to the TelerikWebUI font in Telerik.Windows.Controls.dll.  the font cannot load on Windows XP.

Reproduce it is easy, create one RichEditor project by wizard, and config it to use theme office 2016. then the exe will failed to run on Windows XP.

Attach is sample project.

0
Xiaroun
Top achievements
Rank 1
answered on 10 Mar 2019, 05:21 AM

The problem is introduce from the last version in 2018, and the last version has the same problem.

And you can try open the font in Telerik.Windows.Controls.dll on Windows XP. it will failed.

0
Martin Ivanov
Telerik team
answered on 13 Mar 2019, 02:29 PM
Hi Xiaroun,

This is a known issue and it happens because the glyph font cannot be parsed properly by the WPF framework, on the XP OS. Currently, the only workaround that I can suggest is to avoid applying themes which use the glyphs. Those are the themes before Office2016. In the available themes list those are the ones listed after Office2016Touch.

Regards,
Martin Ivanov
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
Window
Asked by
JEONG-YUN
Top achievements
Rank 1
Answers by
Vladislav
Telerik team
Xiaroun
Top achievements
Rank 1
Martin Ivanov
Telerik team
Share this question
or