This is a migrated thread and some comments may be shown as answers.

Problem with the Office2016 theme

10 Answers 76 Views
RibbonView and RibbonWindow
This is a migrated thread and some comments may be shown as answers.
Patrick
Top achievements
Rank 2
Iron
Iron
Iron
Patrick asked on 21 May 2020, 02:45 PM

Hello,

I have a .NET Core WPF application with the following statement as the first statement of the application:

RadRibbonWindow.IsWindowsThemeEnabled = false;

 

(without this statement, the display is ugly when the application is in full screen, as you can see in your own Report Designer...)

The problem is that, when the application is in full screen mode, it seems that the ribbon is too wide: the first icon at left is near the window edge and the minimize button at the right is partially hidden.

This doesn't appear with the Office2013 theme.

 

10 Answers, 1 is accepted

Sort by
0
Vladimir Stoyanov
Telerik team
answered on 26 May 2020, 07:25 AM

Hello Patrick,

Thank you for the shared code snippet. 

With regards to the icons on the left, I am assuming that you are referring to icons placed in the QuickAccessToolbar. If that is indeed the case, you can create a style targeting that element and increase its Margin:

<Style TargetType="telerik:QuickAccessToolBar">
    <Setter Property="Margin" Value="10 0 0 0" />
</Style>

As for the minimize button, may I ask you to share some sample code demonstrating how the RadRibbonView is defined? You can also provide a picture demonstrating the scenario. This will hopefully allow me to get a better understanding of it and further assist you.

I am looking forward to your reply.

Regards,
Vladimir Stoyanov
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
0
Patrick
Top achievements
Rank 2
Iron
Iron
Iron
answered on 26 May 2020, 07:52 AM

Hello Vladimir,

I'm not talking to the QuickAccessToolbar, but of the icons on the ribbon, Attached are two screenshots with the application maximized and restored, so you can see the difference.

Here is part of the ribbon definition:

<DockPanel>
  <tk:RadRibbonView Name="Ribbon"
              ApplicationButtonContent="  Fichier   "
              ApplicationName="ASLOCA Vaud - Programme de gestion des membres"
              IsMinimizable="True"
              MinimizeButtonVisibility="Visible"
              DockPanel.Dock="Top"
              tk:RadCollapsiblePanel.SmallButtonsPerColumn="3">

 

Please tell me if you need more of the definition of the ribbon.

0
Vladimir Stoyanov
Telerik team
answered on 28 May 2020, 10:44 AM

Hello Patrick,

Thank you for the additional information. 

I tested the scenario on my end, however I was not able to replicate the described behavior. That is why I am attaching the sample project, which I used for testing purposes along with a picture of how the control looks on my end in full screen. Can you check out the shared project and let me know, if the same result is replicated on your end?

If I am missing something, can you modify the sample project and send it over in a new support ticket? (since project files cannot be attached to forum posts) This will hopefully allow me to investigate further and better assist you. 

I am looking forward to your reply.

Regards,
Vladimir Stoyanov
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
0
Patrick
Top achievements
Rank 2
Iron
Iron
Iron
answered on 28 May 2020, 11:42 AM

Hi Vladimir,

Just putting your application in full screen mode shows me the problem without any change... as you can see in the attached screenshot.

0
Vladimir Stoyanov
Telerik team
answered on 02 Jun 2020, 07:39 AM

Hello Patrick,

Thank you for the shared picture. 

As I am unable to replicate the scenario on my end, I would ask you to elaborate a bit on your setup. What are the DPI settings on your end? Do you have multiple monitors? If that is the case, can you try maximizing the application on another monitor? Can you try maximizing a normal WPF Window? Does it exhibit the same behavior? 

Thank you in advance for any help you can provide.

Regards,
Vladimir Stoyanov
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
0
Patrick
Top achievements
Rank 2
Iron
Iron
Iron
answered on 02 Jun 2020, 08:23 AM

Hi Vladimir,

Display is set to 100%. Single monitor setup.

I also have an Office2013 themed WPF that doesn't show this behavior... but the ribbon minimize button at the right is not visible.

If I look at the Live Visual Tree of the application, I can see that the first control to show the problem is the MaximizeWindowsDecorator, whose size is set at 2572,1445. As my monitor has an horizontal resolution of 2560 pixels, this removes 6 pixels both sides horizontally. Attached, please find a screenshot of the Live Visual Tree.

Regards

 

0
Vladimir Stoyanov
Telerik team
answered on 04 Jun 2020, 01:45 PM

Hello Patrick,

Thank you for the shared picture. 

I tried to replicate the scenario in a single monitor setup with a 100% DPI, however I was not able to do so. Is it possible for you to test the sample application on a different machine? If you manage to do so and the behavior is not reproduced, can you check what are the differences in the setups? 

On a side note, can you try the suggestions in the following forum thread: WPF Maximized Window bigger than screen? Alternatively, you can also try handling the SizeChanged event, finding the mentioned element via the ChildrenOfType method and setting its size. 

I am looking forward to your reply.

Regards,
Vladimir Stoyanov
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
0
Patrick
Top achievements
Rank 2
Iron
Iron
Iron
answered on 06 Jun 2020, 06:38 AM

Hi Vladimir,

I've tried my application on my notebook, with a 1920x1080 resolution and I see the same problem...

Your test project also show the same behaviour.

0
Patrick
Top achievements
Rank 2
Iron
Iron
Iron
answered on 08 Jun 2020, 06:55 AM

Hi Vladimir,

on your test PC, try to set the following taskbar setting: Automatically hide the taskbar in desktop mode.

0
Vladimir Stoyanov
Telerik team
answered on 10 Jun 2020, 01:34 PM

Hello Patrick,

Thank you for the additional information. 

I was able to replicate the same behavior on my end and I have logged it in our feedback portal, where you can track its progress: RibbonWindow: The RibbonWindow exceeds the screen area when maximized and the Automatically Hide the Taskbar windows option is enabled. I have also added some telerik points to your account as a thank you for bringing this to our attention. 

For the time being, as a workaround, I can suggest setting the BorderThickness in the SizeChanged event. You can also check for the auto hide setting as suggested here: How to toggle/switch Windows taskbar from “show” to “auto-hide” (and vice-versa)?

I am attaching the sample project updated to demonstrate what I have in mind.

Regards,
Vladimir Stoyanov
Progress Telerik

Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
Our thoughts here at Progress are with those affected by the outbreak.
Tags
RibbonView and RibbonWindow
Asked by
Patrick
Top achievements
Rank 2
Iron
Iron
Iron
Answers by
Vladimir Stoyanov
Telerik team
Patrick
Top achievements
Rank 2
Iron
Iron
Iron
Share this question
or