This is a migrated thread and some comments may be shown as answers.

Problem with Drill Down

5 Answers 45 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Harsha
Top achievements
Rank 1
Harsha asked on 06 May 2015, 10:23 AM

How to view the report without expanding the records when it is open for the first time. Given option is not working(See Image 2). Its just changing the +/- sign of the drill down icon.

Report before Ticking(See Image 3)

Report After Ticking(See Image 1)

5 Answers, 1 is accepted

Sort by
0
Stef
Telerik team
answered on 07 May 2015, 03:38 PM
Hello Harsha,

When you use a ToggleVisibilityAction you need to:
  1. Specify a controlling item and set its Action property;
  2. Select a target item/section and set its Visibility depending on whether it is initially shown or hidden.

For more details check Drilldown Report Action and How to: Add a Drilldown Action.


I hope this helps you.

Regards,
Stef
Telerik
 

See What's Next in App Development. Register for TelerikNEXT.

 
0
Harsha
Top achievements
Rank 1
answered on 10 May 2015, 05:21 AM
Thanks.. It worked !!! :-)
0
BJ
Top achievements
Rank 1
answered on 15 Mar 2017, 01:35 PM

Hi Support,

                I have designed the drill down report, but wanted the report to show by default with Collapse mode ( with + symbol).
                (  Changing values of  Toggle mark initially expanded and DisplayExpandedmark)

                I have tried changing different values of the properties with different combinations but unable to get the desired results.

                Please find the img file having screen shots of the same for more illustrations.

 

    I have tried in visual studio and then in Telrik Report Designer also but all effort goes in vain.

                Could you please comment or give suggestions for the same.
    Your help will be greatly appreciated.

Regards,

BJ

0
BJ
Top achievements
Rank 1
answered on 15 Mar 2017, 01:36 PM

Hi Support,

                I have designed the drill down report, but wanted the report to show by default with Collapse mode ( with + symbol).
                I have tried changing different values of the properties with different combinations but unable to get the desired results.
                Please find the doc file having screen shots of the same for more illustrations.

    I have tried in visual studio and then in Telrik Report Designer also but all effort goes in vain.

                Could you please comment or give suggestions for the same.
    Your help will be greatly appreciated.

Regards,

BJ

0
Katia
Telerik team
answered on 15 Mar 2017, 03:38 PM
Hi BJ,

Check an update in support ticket #1098046 you opened on the same question. For other community members experiencing the same issue, below is the reply from the ticket:

"To show the toggle target initially hidden, uncheck "Toggle mark initially expanded" option in Edit Action dialog. 
Note that this will not hide the toggle target by default when previewing report. To hide inner group, set Visible property of the respective group to false
Check this video that demonstrates the above approach.

More detailed information can be found in Drilldown Report Action help article."


I hope this will help.


Regards,
Katia
Telerik by Progress
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
General Discussions
Asked by
Harsha
Top achievements
Rank 1
Answers by
Stef
Telerik team
Harsha
Top achievements
Rank 1
BJ
Top achievements
Rank 1
Katia
Telerik team
Share this question
or