Pipe symbol not show in qrcode in reporting

1 Answer 20 Views
Report Designer - Web
faris
Top achievements
Rank 1
faris asked on 24 Oct 2023, 08:07 AM

Hi.. 

I have this qrcode string
Fields.ProductMasterCode+"|"+ Fields.ProductName +" | "+ Fields.hashstring

after scan barcode, symbol | (pipe) missing. 

my qcode setting is

encoder - QRCode

ECI - CP437

ErrorCorrectionLevel - L

Mode - Alphanumeric

1 Answer, 1 is accepted

Sort by
0
Todor
Telerik team
answered on 27 Oct 2023, 07:09 AM

Hello Faris,

I confirm the issue with the provided settings.

Note that the ECI setting is only respected when Mode is set to Byte.

When the QR Code Mode is 'Alphanumeric', the characters that may be displayed are the following - see https://en.wikipedia.org/wiki/QR_code:

0–9, A–Z (upper-case only), space, $, %, *, +, -, ., /, :

As a workaround, you may replace '|' with capital 'i', i.e. 'I'.

Regards,
Todor
Progress Telerik

Stay tuned by visiting our roadmap and feedback portal pages, enjoy a smooth take-off with our Getting Started resources, or visit the free self-paced technical training at https://learn.telerik.com/.
Tags
Report Designer - Web
Asked by
faris
Top achievements
Rank 1
Answers by
Todor
Telerik team
Share this question
or