PDF exported does not support Chinese

2 posts, 0 answers
  1. hugo
    hugo avatar
    1 posts
    Member since:
    Mar 2019

    Posted 21 Jun Link to this post

    When displayed on the web page, Chinese is displayed normally, as shown in normal_display.PNG.  

    When exporting PDF, Chinese is displayed abnormally, as shown in abnormal_display.PNG.

    How can export PDF support Chinese?

    How to solve this problem?

  2. Neli
    Admin
    Neli avatar
    121 posts

    Posted 25 Jun Link to this post

    Hi hugo,

    If there are Unicode Glyphs missing on the server, you may see characters replaced with a question mark and if there is a font missing on the client, you may see characters replaced with boxes like in your case. Make sure that the font you use in the report supports the characters that would be displayed. For example when you use a font that does not support non-Latin characters, but then non-Latin characters are added to the report and it is exported to PDF, they would be replaced by question mark character (?) as PDF doesn’t automatically substitute fonts.

    Note that the GDI font substitution in Designer Preview or rendering to HTML behaves differently than PDF.

    To view the list of fonts that are embedded in a PDF file, open the file in Adobe Acrobat and from the File menu, view Properties. The Fonts tab displays the list of fonts that are embedded in the file.

    For more information, visit Design Considerations for PDF Rendering article.

    Regards,
    Neli
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top