Path linking markers being ignored by Map layers

4 posts, 1 answers
  1. Alex
    Alex avatar
    5 posts
    Member since:
    May 2018

    Posted 12 Jun 2018 Link to this post

    https://dojo.telerik.com/@alexy99/EKomOrIh

    I'm trying to follow below document to link markers with Paths, but every layer is ignoring my paths. No error messages.

    https://docs.telerik.com/kendo-ui/controls/diagrams-and-maps/map/how-to/link-marker-to-location

     

    Thanks,

    Alex

  2. Answer
    Konstantin Dikov
    Admin
    Konstantin Dikov avatar
    2466 posts

    Posted 14 Jun 2018 Link to this post

    Hello Alex,

    The HowTo example draws the lines in Shape layer, so you need to include such layer in order to use that approach. Please try appending the shape layer after all other layers and append the line to it.

    Hope this helps.


    Regards,
    Konstantin Dikov
    Progress Telerik
    Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
  3. Alex
    Alex avatar
    5 posts
    Member since:
    May 2018

    Posted 14 Jun 2018 in reply to Konstantin Dikov Link to this post

    https://dojo.telerik.com/@alexy99/ANuGIhAY

    This is the same code as the link-marker-to-location document, but with the tile layer added. It looks like linking markers by paths is not possible with a map tile layer present?

    I tried adding a shape layer to my own code, but it seems the tile layer is still preventing the paths from showing. Is there any work around or is linking markers not possible currently?

  4. Alex
    Alex avatar
    5 posts
    Member since:
    May 2018

    Posted 14 Jun 2018 in reply to Alex Link to this post

    Nevermind I forgot the function locationToView. Thank you.
Back to Top