This is a migrated thread and some comments may be shown as answers.
Path linking markers being ignored by Map layers
3 Answers 2 Views
Map
This is a migrated thread and some comments may be shown as answers.
Alex
Top achievements
Rank 1
Alex asked on 12 Jun 2018, 10:50 PM

https://dojo.telerik.com/@alexy99/EKomOrIh

I'm trying to follow below document to link markers with Paths, but every layer is ignoring my paths. No error messages.

https://docs.telerik.com/kendo-ui/controls/diagrams-and-maps/map/how-to/link-marker-to-location

 

Thanks,

Alex

3 Answers, 1 is accepted

Sort by
0
Accepted
Konstantin Dikov
Telerik team
answered on 14 Jun 2018, 11:19 AM
Hello Alex,

The HowTo example draws the lines in Shape layer, so you need to include such layer in order to use that approach. Please try appending the shape layer after all other layers and append the line to it.

Hope this helps.


Regards,
Konstantin Dikov
Progress Telerik
Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
0
Alex
Top achievements
Rank 1
answered on 14 Jun 2018, 07:47 PM

https://dojo.telerik.com/@alexy99/ANuGIhAY

This is the same code as the link-marker-to-location document, but with the tile layer added. It looks like linking markers by paths is not possible with a map tile layer present?

I tried adding a shape layer to my own code, but it seems the tile layer is still preventing the paths from showing. Is there any work around or is linking markers not possible currently?

0
Alex
Top achievements
Rank 1
answered on 14 Jun 2018, 08:02 PM
Nevermind I forgot the function locationToView. Thank you.
Tags
Map
Asked by
Alex
Top achievements
Rank 1
Answers by
Konstantin Dikov
Telerik team
Alex
Top achievements
Rank 1
Share this question
or