Parameter input field wont show in browser

3 posts, 0 answers
  1. Febryan
    Febryan avatar
    2 posts
    Member since:
    Jun 2018

    Posted 25 Jun 2018 Link to this post

    Greetings.

    I'm just learn how to use telerik reporting app, It still run fine when i'm test it on telerik report designer (pic 1), but when i'm run it on browser the parameter input field not show (pic2)..  i already have set parameter to visible on designer tho.

    did i miss something ? , can someone help me ? .. i need it ASAP.

    Thanks :)

    here's my controller 

    [Route("api/reports")]
        public class ReportsController : ReportsControllerBase
        {
         string reportsPath = string.Empty;
     
            public ReportsController(IHostingEnvironment environment)
            {
                 
                this.reportsPath = Path.Combine(environment.WebRootPath, "Reports");
                 
                this.ReportServiceConfiguration = new ReportServiceConfiguration
                {
                    HostAppId = "ReportingApp",
                    Storage = new FileStorage(),
                    ReportResolver = new ReportFileResolver(reportsPath)
                    //ReportResolver = new ReportTypeResolver()
                    //                    .AddFallbackResolver(new ReportFileResolver(this.reportsPath)),
                };
     
     
                
            }
     
            [HttpGet("reportlist")]
            public IEnumerable<string> GetReports()
            {
                return Directory
                    .GetFiles(this.reportsPath)
                    .Select(path =>
                        Path.GetFileName(path));
            }
     
     
            [HttpGet("test")]
            public string test()
            {
                 
                return    this.reportsPath.ToString() ;
            }
     
     
        }

     

    and my view :

    <!DOCTYPE html>
     
    <html>
    <head>
        <title>Mutasi Printout</title>
     
        <meta http-equiv="X-UA-Compatible" content="IE=edge" />
        <meta charset="utf-8" />
        <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
     
        <script src="https://code.jquery.com/jquery-2.2.4.min.js" integrity="sha256-BbhdlvQf/xTY9gja0Dq3HiwQF8LaCRTXxZKRutelT44=" crossorigin="anonymous"></script>
     
        <link href="http://kendo.cdn.telerik.com/2015.3.930/styles/kendo.common.min.css" rel="stylesheet" id="common-css" />
        <link href="http://kendo.cdn.telerik.com/2015.3.930/styles/kendo.blueopal.min.css" rel="stylesheet" id="skin-css" />
     
        <!--kendo.all.min.js can be used instead-->
     
        <script src="js/telerikReportViewer.kendo-12.1.18.516.min.js"></script>
        <script src="js/telerikReportViewer-12.1.18.516.min.js"></script>
        <script src="js/themeSwitcher.js"></script>
     
        <style>
            body {
                font-family: Verdana, Arial;
                margin: 5px;
            }
     
            #reportViewer1 {
                position: absolute;
                left: 5px;
                right: 5px;
                top: 40px;
                bottom: 5px;
                overflow: hidden;
                clear: both;
            }
     
            #theme-switcher {
                float: right;
                width: 12em;
                height: 30px;
            }
        </style>
    </head>
    <body>
        <select id="theme-switcher"></select>
     
        <div id="reportViewer1">
            loading...
        </div>
     
        <script type="text/javascript">
            $(document).ready(function () {
                //Theme switcher
                themeSwitcher(
                    '#theme-switcher',
                    '#common-css',
                    '#skin-css');
                 
                $("#reportViewer1")
                    .telerik_ReportViewer({
                        serviceUrl: "api/reports/",
                        reportSource: {
     
                            report: "BasketSize.trdp",
     
                            parameters: {}
                        },
     
                        viewMode: telerikReportViewer.ViewModes.INTERACTIVE,
                        scaleMode: telerikReportViewer.ScaleModes.SPECIFIC,
                        scale: 1.0,
     
                      
                       // enableAccessibility: false
                    });
            });
        </script>
     
    </body>
    </html>

     

     

  2. Febryan
    Febryan avatar
    2 posts
    Member since:
    Jun 2018

    Posted 27 Jun 2018 Link to this post

    anyone ..? , im still waiting for answer 
  3. Silviya
    Admin
    Silviya avatar
    414 posts

    Posted 28 Jun 2018 Link to this post

    Hello Febryan,

    This is not a known issue.
    From the provided screen shots, I see that both parameters areas' visibility is true (in the designer there is a button "Parameters area" in Settings tab, in the HTML5 Report Viewer there is a button like a funnel in the toolbox).

    Please have in mind that by default, the HTML5 Viewer's parameters area is positioned on the right sight of the viewer, not at the top.

    My assumption is that you've applied some custom CSS to the viewer's elements to hide it. Please inspect the page with Developer Tools (F12) and check for additional styles on the parameters area.

    Regards,
    Silviya
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top