This is a migrated thread and some comments may be shown as answers.

Paging numbers not showing when PagerStyle-AlwaysVisible set to true

7 Answers 372 Views
Grid
This is a migrated thread and some comments may be shown as answers.
TONSIR
Top achievements
Rank 1
TONSIR asked on 25 Feb 2010, 03:38 PM
I have the following rad grid on my aspx page.  When I don't specify the PagerStyle-AlwaysVisible property in the MasterTableView the paging numbers show up as expected (see exhibitA.jpg).  When I add the PagerStyle-AlwaysVisible property to the MasterTableView the paging numbers are gone (see exhibitB.jpg).  I am setting the PagerStyle-AlwaysVisible property because I want the paging information (number of results, etc) to show up even if there is only one page of results (by default the pager information does not display if there is only one page of results returned).

<rad:RadGrid ID="RadGrid1" PageSize="15" AllowPaging="True" runat="server" AutoGenerateColumns="false" BorderStyle="None">

 

 

<PagerStyle Mode="NextPrevAndNumeric" />

 

 

<MasterTableView PagerStyle-AlwaysVisible="true">

 

 

<SortExpressions>

 

 

<rad:GridSortExpression FieldName="Title" SortOrder="Ascending" />

 

 

</SortExpressions>

 

 

<Columns>

 

 

<rad:GridHyperLinkColumn HeaderText="Programs" DataTextField="Title" DataNavigateUrlField="Quicklink"></rad:GridHyperLinkColumn>

 

 

</Columns>

 

 

</MasterTableView>

 

 

</rad:RadGrid>

Any ideas??

Thanks,
Tony

 

7 Answers, 1 is accepted

Sort by
0
Pavlina
Telerik team
answered on 26 Feb 2010, 07:48 AM
Hi Tony,

The grid pager problem is a known bug in the beta version of Q1 2010 release of RadControls for ASP.NET AJAX. It is already logged in our bug-tracking system and our developers will address it for the official release of the controls.
 
Please excuse us for the temporary inconvenience.

Regards,
Pavlina
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
TONSIR
Top achievements
Rank 1
answered on 26 Feb 2010, 03:05 PM
Hi Pavlina,

Thanks for the reply.  I am using RadControls Q3 2007 SP2.  Is it a bug in this version as well and will it be patched?

Thanks,
Tony
0
Pavlina
Telerik team
answered on 01 Mar 2010, 02:36 PM
Hi Tony,

I followed your scenario in order to replicate the issue you are facing with version Q3 2007 SP2, but to no avail. Please find attached a simple working application which is working properly and let me know if other questions or problems arise.

Greetings,
Pavlina
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
TONSIR
Top achievements
Rank 1
answered on 05 Mar 2010, 10:12 PM
Hi Pavlina,

I ended up dealing with the problem by setting the property in code behind based on record count.  So if the number of returned records would only result in one page I set AlwaysVisible to true otherwise set to false. This provides me with the result I need.  Here is my code in case anyone else needs to do something similar;

        If RadGrid1.MasterTableView.Items.Count > 15 Then  
            RadGrid1.PagerStyle.AlwaysVisible = False 
        Else  
            RadGrid1.PagerStyle.AlwaysVisible = True 
        End If 


Regards,
Tony

0
Richard
Top achievements
Rank 2
answered on 22 Mar 2010, 08:15 PM
Did this bug ever get resolved?  I am using the Q1 2010 controls and noticed that the pager now goes away when I have less records than what the pager is set to.  I have "AlwaysVisible" set to true but that value is being ignored.

0
Pavlina
Telerik team
answered on 23 Mar 2010, 01:13 PM
Hello Richard,

Please set AlwaysVisible property for the MasterTableView in order to achieve your goal:
ASPX:
<MasterTableView...
... 
     <PagerStyle Mode="NextPrevNumericAndAdvanced" AlwaysVisible="true" />       
    
</MasterTableView>

Give it a try and let us know of the result.

All the best,
Pavlina
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Richard
Top achievements
Rank 2
answered on 23 Mar 2010, 02:01 PM
Yeah, that did the trick!  Thanks Pavlina.
Tags
Grid
Asked by
TONSIR
Top achievements
Rank 1
Answers by
Pavlina
Telerik team
TONSIR
Top achievements
Rank 1
Richard
Top achievements
Rank 2
Share this question
or