This is a migrated thread and some comments may be shown as answers.

Orphan controls after deleting

1 Answer 28 Views
Toolstrip (obsolete as of Q3 2010)
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
JulioR
Top achievements
Rank 1
JulioR asked on 10 Dec 2007, 09:29 AM
Hi,

I'm having problems each time I try to delete a radtoolstripitem or a radtoolstrip at design time. The extrange behavior is that the controls inside the radtoolstripitem (buttons) are still in the form after deleting the parent control and click on Undo. Now I can select the "ghost" buttons on the properties panel in VS 2005, but I can not see any of them on the form itself.

Is the Undo option in VS 2005 not working well with Telerik controls?

How can I see again at design time those controls?

I have tried with Microsoft controls and everything is working fine, so I suppose its a Telerik problem.

Thanks in advance,
Julio

1 Answer, 1 is accepted

Sort by
0
Boyko Markov
Telerik team
answered on 10 Dec 2007, 01:33 PM
Hi JulioR,

We confirm the issues regarding VS 2005 design time behavior with custom controls, however they are not related to Telerik per se. You will experience similar issues with other 3rd party custom controls.

We are still researching how Microsoft have managed to overcome this problem with their controls and we will fix all issues that arise from our controls in design-time, starting with RadToolStrip.

Thank you very much for your feedback. Your points have been updated!


Regards,
Boyko Markov
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
Toolstrip (obsolete as of Q3 2010)
Asked by
JulioR
Top achievements
Rank 1
Answers by
Boyko Markov
Telerik team
Share this question
or