This is a migrated thread and some comments may be shown as answers.

Not Rendering Barcode Correctly

1 Answer 77 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Steve
Top achievements
Rank 1
Steve asked on 14 Feb 2011, 10:43 PM
Hi,

I am using the Q3 2010 version of reporting and am trying to implement barcodes on a report.  I have dropped the barcode control on the report and set the value equal to the value of a field in the database (=Fields.BarcodeValue).  When rendered using symbology "Code 39", checksum on or off, the value cannot be read by the reader (ZB-8150).  If I set the barcode value property equal to a set value (12345), the barcode renders correctly and can be read with no problem.  The only time I have an issue is when I try to read a value from the database.  Please Help!  This is an essential part of the project I an working on.

Steve C.

1 Answer, 1 is accepted

Sort by
0
Peter
Telerik team
answered on 17 Feb 2011, 02:33 PM
Hello Steve,

We have made some tests locally and we are unable to confirm the described behavior with a DB int type 1234. Thus we will need more information in order to further investigate the issue:
  • What is the DB data type and the values that are retrieved from the database?
  • What is the Barcode item's size?
  • Is the Barcode.Stretch property set to true? If you have set it to True it's possible that there are two many elements and resulted barcodes have resolution less than 0.1mm. 
Greetings,
Peter
the Telerik team
Tags
General Discussions
Asked by
Steve
Top achievements
Rank 1
Answers by
Peter
Telerik team
Share this question
or