This is a migrated thread and some comments may be shown as answers.

No Telerik controls in Design view

27 Answers 691 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Patrik
Top achievements
Rank 1
Patrik asked on 19 Feb 2013, 12:33 PM
Hi everyone,

out of nowhere my telerik controls stopped to display in VS Designer.

Could you help me what should I do to bring them back?

Thank you for your replies.

27 Answers, 1 is accepted

Sort by
0
Dimitrina
Telerik team
answered on 19 Feb 2013, 04:28 PM
Hello,

May I ask you to share what is the version of the RadControls do you use? Do you get any errors in design time?

Kind regards,
Didie
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
Patrik
Top achievements
Rank 1
answered on 19 Feb 2013, 04:37 PM
Hi Didie,

no, I do not get any errors. All the controls are fine in XAML, they just disappeared from designer (but not all of them, for example RadGridView is still visible in designer). It happened today in spite the fact nothing has changed within the project nor the solution. We are using the latest version of RadControls - downloaded few days ago.

When I build and run the application it seems to be working as expected, but it is hard to design any form and style the controls when they are not displayed in designer.

Thank you
0
Dimitrina
Telerik team
answered on 19 Feb 2013, 05:26 PM
Hello,

Would you please try to Clean and then Rebuild your solution?

Regards,
Didie
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
Patrik
Top achievements
Rank 1
answered on 19 Feb 2013, 05:31 PM
I have already tried that and it did not help. Do you please have any other idea how to solve this? Or at least what could have caused it?

Thank you
0
Dimitrina
Telerik team
answered on 20 Feb 2013, 08:35 AM
Hello,

Does it happen in a single view, or in all of them? Would it be possible to limit the problem to a single control, commenting the controls definitions one by one? Does it happen if you create a new window and drag a control there? 


Kind regards,
Didie
the Telerik team

Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

0
Patrik
Top achievements
Rank 1
answered on 20 Feb 2013, 11:42 AM
Hi,

we tried to re-run the telerik configuration on the project and it worked. All controls are visible in designer again. On the other hand still no idea what could have caused this behavior.

Thank you for your replies. 
0
Mark
Top achievements
Rank 1
answered on 14 May 2013, 11:56 PM
This happened to me as well, and threw me into a gut-wrenching panic for a while. Thankfully I found this post and sure enough, re-running Telerik->RadControls -> Configure Project somehow fixed the problem. I too have no idea what could have happened. It was working fine last night, then opened the projected today and no RadControls would display (though the application ran and showed the controls just fine).
0
Aurelio Righetti
Top achievements
Rank 1
answered on 27 May 2014, 04:23 PM
Hi.. i have the same problem, with version 2014_1_0428 in the designer (VS2013) the RadGridView is show ok..with the internal version 2014_1_0512 - 2014_1_0519 - 2014_1_0526, in the designer appear the error:

telerik radgridview not exist in the namespace http://schemas.telerik.com/2008/xaml/presentation
and the designer won't show null.

with blend work OK.

Thanks
Aurelio
0
Yoan
Telerik team
answered on 30 May 2014, 02:31 PM
Hello Aurelio,

We are not aware of such an issue with the current version of RadGridView. May I ask you to perform the following steps:

        1. Open the project and remove all Telerik's references.
        2.     Save the project and close it. 
        3.     Open the project directory and delete "Bin" and "Obj" folders.
        4.     Open the project and add the references.
        5.     Build the project.

Sometimes this helps to resolve the designer's errors and I hope that in your case will be that way.

Regards,
Yoan
Telerik
 
Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
 
0
Aurelio Righetti
Top achievements
Rank 1
answered on 03 Jun 2014, 04:56 PM
Hello Yoan,
I have execute the step, but the problem appear and in the toolbox of the VS 2013 not appear the component, the project il compiled and work ok, in blend in ok, but in the designer xaml, the component not appear and retrive the same error.

I reinstall the version 2014_1_0428

Thanks
Aurelio
0
Dimitrina
Telerik team
answered on 04 Jun 2014, 02:35 PM
Hi,

May I ask you to create a new project adding RadGridView to it? Do you get the same error? If so, may I ask you to send me this test project so that I can check it locally?
You can open a new support thread and attach it there.

Regards,
Didie
Telerik
 
Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
 
0
yu yang
Top achievements
Rank 1
answered on 15 Mar 2017, 03:52 AM
I have run into same problem, finally I closed all visual studio windows, and restart visual studio, the telerik control show in design again.
0
yu yang
Top achievements
Rank 1
answered on 15 Mar 2017, 05:45 AM
correct: I have run into same problem, finally I Click "Telerik > UI FOr WPF > Configure Project", then restart visual studio, the telerik control show in design again.
0
Robert
Top achievements
Rank 1
answered on 20 Mar 2017, 06:36 PM

Just experienced the same issue with VS 2017 and current WPF controls.

I confirm that "Telerik > UI For WPF > Configure Project", then restart visual studio worked for me as well.

Now if I could only get the demos to install...

0
Stefan
Telerik team
answered on 23 Mar 2017, 01:40 PM
Hello Yu Yang, Robert,

I am happy that you have managed to find a solution and the designer is now working as expected.

Robert, though I am not sure what issue you are experiencing while installing our WPF demos, I suggest  you checking out the Installing WPF Demos article.

If further assistance regarding the WPF demos is required, I would kindly ask you to open a new thread and post your enquiry in it, so the threads are kept consistent.

Thanks in advance for understanding.

Regards,
Stefan X1
Telerik by Progress
Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
0
Robert
Top achievements
Rank 1
answered on 23 Mar 2017, 04:19 PM

If I do "Install" from page http://demos.telerik.com/wpf/ it frequently sticks at 4.85mb download, without any notification of why.

If I do "Launch," I get the download ok but then the progress sticks at "1" when opening the demos application.

As usual for medium to big companies, we have corporate-level firewall and anti-virus that may block some suspected file signatures or url's.

After leaving it at "1" while I was typing here, it finally went to an error I could open in Visual Studio which reported a system.io exception with message: " 'Could not load file or assembly 'Application, Version=1.0.0.0, Culture=neutral, PublicKeyToken=5803cfa389c90ce7' "

This is on Windows 10 Pro. I have no cache files in "~AppData\Local\Apps\2.0", nor is there even a folder there named "Apps." 

I have no previous version to uninstall since upgrading this machine from Windows 7.

I would like to have local demos, but not if I have to install SQL Server express to do so. I have SQL Server 2016 Developer edition installed.

Thanks

0
Lance | Manager Technical Support
Telerik team
answered on 23 Mar 2017, 10:38 PM
Hi Robert,

Alternatively, you can use the SDK Sample Browser. It lets you browse and open individual demos directly in Visual Studio without the overhead of the entire solution or other external dependencies. 

This approach lightweight and easy to explore, here's a screenshot on my end showing an example of checking out a GridView demo:









Regards,
Lance | Tech Support Engineer, Sr.
Telerik by Progress
Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
0
Robert
Top achievements
Rank 1
answered on 23 Mar 2017, 10:45 PM

Immediate error trying to install that also:

PLATFORM VERSION INFO
 Windows    : 10.0.14393.0 (Win32NT)
 Common Language Runtime  : 4.0.30319.42000
 System.Deployment.dll   : 4.6.1586.0 built by: NETFXREL2
 clr.dll    : 4.6.1637.0 built by: NETFXREL3STAGE
 dfdll.dll    : 4.6.1586.0 built by: NETFXREL2
 dfshim.dll    : 10.0.14393.0 (rs1_release.160715-1616)
SOURCES
 Deployment url   : http://demos.telerik.com/xaml-sdkbrowser/SDKSamplesBrowser.application
      Server  : Microsoft-IIS/7.5
      X-Powered-By : ASP.NET
 Deployment Provider url  : http://demos.telerik.com/xaml-sdkbrowser/SDKSamplesBrowser.application
 Application url   : http://demos.telerik.com/xaml-sdkbrowser/Application%20Files/SDKSamplesBrowser_2017_03_07_1301/SDKSamplesBrowser.exe.manifest
      Server  : Microsoft-IIS/7.5
      X-Powered-By : ASP.NET
IDENTITIES
 Deployment Identity  : SDKSamplesBrowser.application, Version=2017.3.7.1301, Culture=en, PublicKeyToken=e853e47715c765ec, processorArchitecture=msil
 Application Identity  : SDKSamplesBrowser.exe, Version=2017.3.7.1301, Culture=en, PublicKeyToken=e853e47715c765ec, processorArchitecture=msil, type=win32
APPLICATION SUMMARY
 * Installable application.
 * Trust url parameter is set.
ERROR SUMMARY
 Below is a summary of the errors, details of these errors are listed later in the log.
 * Activation of http://demos.telerik.com/xaml-sdkbrowser/SDKSamplesBrowser.application resulted in exception. Following failure messages were detected:
  + Exception occurred loading manifest from file Mono.Security.dll: the manifest may not be valid or the file could not be opened.
  + File Mono.Security.dll is not a valid Portable Executable (PE) file.
  + File {0} is not a valid Portable Executable (PE) file.
COMPONENT STORE TRANSACTION FAILURE SUMMARY
 No transaction error was detected.
WARNINGS
 There were no warnings during this operation.
OPERATION PROGRESS STATUS
 * [3/23/2017 3:44:30 PM] : Activation of http://demos.telerik.com/xaml-sdkbrowser/SDKSamplesBrowser.application has started.
 * [3/23/2017 3:44:31 PM] : Processing of deployment manifest has successfully completed.
 * [3/23/2017 3:44:31 PM] : Installation of the application has started.
 * [3/23/2017 3:44:31 PM] : Processing of application manifest has successfully completed.
 * [3/23/2017 3:44:34 PM] : Found compatible runtime version 4.0.30319.
 * [3/23/2017 3:44:34 PM] : Request of trust and detection of platform is complete.
ERROR DETAILS
 Following errors were detected during this operation.
 * [3/23/2017 3:44:35 PM] System.Deployment.Application.InvalidDeploymentException (ManifestLoad)
  - Exception occurred loading manifest from file Mono.Security.dll: the manifest may not be valid or the file could not be opened.
  - Source: System.Deployment
  - Stack trace:
   at System.Deployment.Application.Manifest.AssemblyManifest.ManifestLoadExceptionHelper(Exception exception, String filePath)
   at System.Deployment.Application.Manifest.AssemblyManifest.LoadFromInternalManifestFile(String filePath)
   at System.Deployment.Application.DownloadManager.ProcessDownloadedFile(Object sender, DownloadEventArgs e)
   at System.Deployment.Application.FileDownloader.DownloadModifiedEventHandler.Invoke(Object sender, DownloadEventArgs e)
   at System.Deployment.Application.FileDownloader.OnModified()
   at System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
   at System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
   at System.Deployment.Application.FileDownloader.Download(SubscriptionState subState, X509Certificate2 clientCertificate)
   at System.Deployment.Application.DownloadManager.DownloadDependencies(SubscriptionState subState, AssemblyManifest deployManifest, AssemblyManifest appManifest, Uri sourceUriBase, String targetDirectory, String group, IDownloadNotification notification, DownloadOptions options)
   at System.Deployment.Application.ApplicationActivator.DownloadApplication(SubscriptionState subState, ActivationDescription actDesc, Int64 transactionId, TempDirectory& downloadTemp)
   at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
   at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
   at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
  --- Inner Exception ---
  System.IO.IOException
  - File Mono.Security.dll is not a valid Portable Executable (PE) file.
  - Source: System.Deployment
  - Stack trace:
   at System.Deployment.Application.PEStream.ConstructFromFile(String filePath, Boolean partialConstruct)
   at System.Deployment.Application.Manifest.AssemblyManifest.LoadFromInternalManifestFile(String filePath)
  --- Inner Exception ---
  System.ComponentModel.Win32Exception
  - File {0} is not a valid Portable Executable (PE) file.
  - Source: System.Deployment
  - Stack trace:
   at System.Deployment.Application.PEStream.DosHeader..ctor(FileStream file)
   at System.Deployment.Application.PEStream.ConstructPEImage(FileStream file, Boolean partialConstruct)
   at System.Deployment.Application.PEStream.ConstructFromFile(String filePath, Boolean partialConstruct)
COMPONENT STORE TRANSACTION DETAILS
 No transaction information is available.

0
Robert
Top achievements
Rank 1
answered on 23 Mar 2017, 10:46 PM
Why can't these things have an administrative download with non-dependent local installer? (As opposed to web stub launch/install)
0
Lance | Manager Technical Support
Telerik team
answered on 24 Mar 2017, 02:42 PM
Hello Robert,

Since you can't seem to install any apps, you can get the full source code for those demos here. The SDK Sample Browser syncs up with that GitHub repo and does a fetch, it's the same code as you'd use in the local application.

Another option you can use is to just get the full source code of the Product Demos, as a ZIP folder, from your account.

Here are the steps:

1 - Log into www.telerik.com
2 - Go to the UI for WPF downloads page
3 - Scroll down the "Resources" section
4 - Download the following file: Telerik_UI_for_WPF_[VERSION NUMBER]_Demos.zip

In that folder you'll find a full Visual Studio Solution with all the demos and the QSF (the framework that launches and displays the demos).

Let us know if you have any further trouble.

Regards,
Lance | Tech Support Engineer, Sr.
Telerik by Progress
Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
0
Laure
Top achievements
Rank 1
Iron
answered on 25 Jul 2017, 12:45 PM

Hi, I would like to share my experience for developers who will my have the same problem. I had the same problem with Wpf controls version 2017.2.614.45.

I tried all solutions in this page whithout any positif result.

In my ca

se, the .NET Framework version of the project was 4.5. I changed it to 4.6 and bingo!

I hope this can help to somebody.

Thanks.

0
Mando
Top achievements
Rank 1
answered on 10 Oct 2017, 11:50 AM

Hello guys,

here is the fastest solution for this issue

Follow the below steps:

1- From the Solution Explorer open the design code ( Example: FormName.Designer.cs )

2- Copy the whole content to external text file and save it for later use.

3- Open the form which have the issue and click on empty space on the form and press CTRL + A to select all the controls.

4- Press CTRL + X to cut all the controls and then the form will be empty.

5- Press CTRL + V to paste them again on the same form

You will notice all the controls came back to their places as nothing happened but actually they lost their connection with their functions.

6- Now save the form and close it then open the designer code file again and restore the contents you saved in the text file.

7- Save and open the form again it will work as it was before.

hope this help

0
Lance | Manager Technical Support
Telerik team
answered on 10 Oct 2017, 05:56 PM
Hello Mando,

It appears you're speaking about Winforms application. The issue in this thread is for WPF, which doesn't have a designer.cs file. Instead it uses XAML for the UI and a cs (or vb) code-behind.

I recommend sharing that nice workaround in the UI for Winforms forums here.

Regards,
Lance | Tech Support Engineer, Sr.
Progress Telerik
Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
0
Mando
Top achievements
Rank 1
answered on 11 Oct 2017, 04:01 PM

Hello Lance,

Yeah I know it is WPF here but I think it is the same issue and the same solution except the XAML instead of designer, Will be so easy for developers to know the different

and they can use almost the same steps

however I posted it here 

http://www.telerik.com/forums/hidden-controls-in-design-view-solution

0
Jon
Top achievements
Rank 1
answered on 11 May 2018, 08:59 PM

Yes - this is definitely a problem in VS 2017 for me as well...

sorry for being dense :) - but could you explain what 

Telerik > UI For WPF > Configure Project

means? Where are you seeing this? 

Much thanks - Jon

 

0
Jon
Top achievements
Rank 1
answered on 11 May 2018, 09:15 PM
That's a dead link.
0
Lance | Manager Technical Support
Telerik team
answered on 14 May 2018, 02:41 PM
Hi Jon,

If you're not seeing controls in the VS Designer, the very first thing to try is a Clean and Rebuild of the WPF project. This usually fixes most designer issues.

Next, it's also possible that the VS toolbox is using an older/different version of UI for WPF, while the project is trying to use newer ones. To fix this, use the Toolbox Configurator to make sure the Toolbox is using the correct version.

To clarify what I mean about the tool, you can find them in the Telerik Visual Studio menu. Here's a screenshot:




Configure Project updates the Telerik UI for WPF assemblies for that project, and the Toolbox Configurator updates the toolbox to use a specific version.

Regards,
Lance | Tech Support Engineer, Sr.
Progress Telerik
Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
Tags
General Discussions
Asked by
Patrik
Top achievements
Rank 1
Answers by
Dimitrina
Telerik team
Patrik
Top achievements
Rank 1
Mark
Top achievements
Rank 1
Aurelio Righetti
Top achievements
Rank 1
Yoan
Telerik team
yu yang
Top achievements
Rank 1
Robert
Top achievements
Rank 1
Stefan
Telerik team
Lance | Manager Technical Support
Telerik team
Laure
Top achievements
Rank 1
Iron
Mando
Top achievements
Rank 1
Jon
Top achievements
Rank 1
Share this question
or