No data message for Table

2 posts, 0 answers
  1. Mateusz
    Mateusz avatar
    12 posts
    Member since:
    Jul 2012

    Posted 29 Aug Link to this post

     Hello, 

    I have few reports when I am using data tables (like in att1) and everything was working really nice, but then i have upgraded Reporting to  R2 2017. The problem is that if there is no Data returned for my table i was using property "NoDataMessage" to display some text (att2). In newest version if i put anything into "NoDataMessage" property it crashes my report with

    "Index was out of range. Must be non-negative and less than the size of the collection.
    Parameter name: index"

     

    The only way to make it work is to leave this property empty, or to set it's value to some integer (but it won't be displayed anyway). I do not really want to modify the queries as it was really handy to display Text when there was no data returned from database.  

     

    Can anyone help me with this?

     

     

  2. Peter
    Admin
    Peter avatar
    1629 posts

    Posted 30 Aug Link to this post

    Hello Mateusz,

    This is a known issue that we have already fixed in the latest internal build (11.1.17.822). Please upgrade your Telerik Reporting installation and let us know if you need additional assistance.

    Regards,
    Peter
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top