This is a migrated thread and some comments may be shown as answers.
New Install, VS2008 fails to create report
2 Answers 34 Views
This is a migrated thread and some comments may be shown as answers.
Kevin
Top achievements
Rank 2
Kevin asked on 15 Jul 2010, 04:39 PM
I just installed Reporting.  I went into VS2010 to create a new report in an existing project.
The error I got was: "The designer could not be showed for this file because none of the classes within it can be designed..."

If I open the code, Visual Studio says it can't find "Telerik.Reporting".  There is a reference to Telerik.Reporting in the project.

I don't know if it makes a difference, but I am using 2008.3.1314.35 of the Telerik.Web.UI tools.  Also, reporting works fine in VS2010.

Thanks!

2 Answers, 1 is accepted

Sort by
0
Accepted
Steve
Telerik team
answered on 16 Jul 2010, 04:40 PM
Hi Kevin,

The error I got was: "The designer could not be showed for this file because none of the classes within it can be designed..."
Have you by any chance added the Telerik Report to a web site directly? If this is the case, please create separate class library, add the reports there and reference the class library into your web site.
Generally VS2010 support has been claimed in the Q1 SP1 2010 release, thus it is highly likely to have problems with 2008 product version in VS2010. If the main IDE you're using in your daily work is VS2010, we highly recommend that you download and install the latest official release - Q2 2010.

Kind regards,
Steve
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Kevin
Top achievements
Rank 2
answered on 22 Jul 2010, 02:06 PM
Putting everything in a class library fixed the issues.

Thanks,
Kevin
Asked by
Kevin
Top achievements
Rank 2
Answers by
Steve
Telerik team
Kevin
Top achievements
Rank 2
Share this question
or