This is a migrated thread and some comments may be shown as answers.

new install

4 Answers 142 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Amanda
Top achievements
Rank 2
Amanda asked on 14 Jul 2009, 05:35 PM
I downloaded and installed the new version of all the Telerik controls.  I am in a project that I've been working on for awhile and some of my design pages will not load or when I run/test the program, it doesn't work because now some "object references are not set to an instance of an object."  When I open a design page, I get errors like this (and I can't see teh design page at all):  "No such property registered: IsPressed, Telerik.WinControls.UI.RadButtonItem" or "No such property registered: NumberOfColors, Telerik.WinControls.UI.LightVisualElement" or just "Object reference not set to an instance of an object"  Is there something else I need to do besides just installing the new version of the Telerik controls?

4 Answers, 1 is accepted

Sort by
0
Amanda
Top achievements
Rank 2
answered on 14 Jul 2009, 07:33 PM
Alright, so my coworker installed the new version and received the same problem.  When he unsinstalled the new rad controls and rolled back to the older version of the program, everything is working fine.  So, he reinstalled the rad controls and built the program and once again, the program creates the errors listed above in my first post.  He tried deleting all the telerik references, closing VS, reopening and building, no change.  He also removed and added all the same rad control references (both the old and the new) and it's still showing the error.  Once he uninstalls the rad controls (newest version, Q2 2009), everything is working fine.  So is there a bug or something in the new install that's creating a problem or something?
0
Victor
Telerik team
answered on 15 Jul 2009, 03:02 PM
Hello Amanda,

The designer issue is related to referenced Telerik assemblies with different versions. Please verify that all assemblies referenced have the same version. Here is a help article explaining the upgrade process.
I hope this information will help.
Let us know if you need further assistance with this.

Greetings,
Victor
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Diederik
Top achievements
Rank 1
answered on 01 Sep 2009, 07:24 AM
Hello,

One day, without any apparent reason, we were experiencing the same problem with some forms that were previously created. We hadn't done any upgrade to a new version of the Telerik Wincontrols recently.  This happened only on two developer boxes and not on some others. We tried to solve the problem following the upgrade process as described in the link above. This did not solve the problem for us.

Configuration for both boxes is:
- Windows Vista
- Visual Studio 2005
- Visual Studio 2008
- SQL Server Developer

All Microsoft software is fully patched.

- Telerik WinControls 2009 Q1SP1
- Telerik Ajax WebControls 2009 Q2

After trial and error we discovered that removing the Telerik.VSX assemblies from the GAC solved the problem. We were puzzled since these assemblies are installed as part of the Telerik Ajax WebControls 2009 Q2.

So our hypothesis is that there is some inconsistency between the Telerik WinControls 2009 Q1SP1 and Telerik Ajax WebControls 2009 Q2.

We uninstalled the Telerik Ajax WebControls 2009 Q2 on the second box to test the hypothesis. This solved the problem. The boxes that didn't have any problem also did not have the WebControls installed.

Hope this helps to solve the problem.
0
Victor
Telerik team
answered on 02 Sep 2009, 02:58 PM
Hello Diederik,

Thank you for writing. We are aware of this issue, but there were very few users which experienced it and we have not been able to find out the reason as we could not reproduce it. This happened during the beta release of Q2 2009 and disappeared afterwards. You can upgrade to the latest version and the problem should disappear, at least this worked for the users who experienced it. Please write again if you have other questions.

Kind regards,
Victor
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Tags
General Discussions
Asked by
Amanda
Top achievements
Rank 2
Answers by
Amanda
Top achievements
Rank 2
Victor
Telerik team
Diederik
Top achievements
Rank 1
Share this question
or