This is a migrated thread and some comments may be shown as answers.

Need explanation on something fixed in R1 2020 SP1

3 Answers 11 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Laurent
Top achievements
Rank 1
Iron
Laurent asked on 19 Feb 2020, 04:19 PM

H team,

Found this many times in last kendo UI release note :

"Input wrapped in class - 'input-validation-error' is not submitted by jquery-validate greater than version 1.12.0"

Can someone explain me this in details please ?

 

Best regards,

Laurent.

 

3 Answers, 1 is accepted

Sort by
0
Ivan Danchev
Telerik team
answered on 21 Feb 2020, 02:06 PM

Hello Laurent,

This issue is repeated multiple times in the release notes, because it is a fix of a bug that affected multiple components: https://github.com/telerik/kendo-ui-core/issues/5595

The widgets (listed in the labels in the linked issue) that render an input element wrapped in another element that has the "input-validation-error" class applied, were not submitting their values with the form data.

The bug is fixed in R1 2020 SP1.

Regards,
Ivan Danchev
Progress Telerik

Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
0
Laurent
Top achievements
Rank 1
Iron
answered on 21 Feb 2020, 02:11 PM

Hi Ivan,

Thank you for your prompt response.

So, it only concerns those using the "jQuery validation plugin" ? 

0
Ivan Danchev
Telerik team
answered on 21 Feb 2020, 05:28 PM

Laurent,

Yes, it concerns users of the plugin (versions newer than 1.12.0).

Regards,
Ivan Danchev
Progress Telerik

Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
General Discussions
Asked by
Laurent
Top achievements
Rank 1
Iron
Answers by
Ivan Danchev
Telerik team
Laurent
Top achievements
Rank 1
Iron
Share this question
or