This is a migrated thread and some comments may be shown as answers.

NavigateBackEnabled=false, in ASP.NET Ajax?

0 Answers 21 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Jeff
Top achievements
Rank 1
Jeff asked on 14 Oct 2013, 05:12 PM
I'm trying to hide the navigate-forward and navigate-back buttons in the Telerik Report viewer, on an ASP.NET page.

Browsing through the documentation on the website, I find NavigateBackEnabled as a property of ReportViewerBase, which is in the Telerik.ReportViewer.WinForms namespace.

I cannot find NavigateBackEnabled in the Telerik.ReportViewer.WebForms namespace, and intellisense does not list NavigateBackEnabled as an option for <telerik:ReportViewer>.  If I set NavigateBackEnabled="false", despite the lack of intellisense, I get javascript errors in your ReportViewer.prototype.OnReportLoaded(), when I run a report the second time, and the navigate-back button is still enabled.

Our problem is that when the user clicks on navigate-forward or navigate-back, we get errors:

An error occurred while executing interactive action.
Unable to translate bytes [97] at index 0 from specified code page to Unicode.

  Given that this is not a function we intended to provide to our customers, rather trying to dig into why this is happening, we'd rather simply remove the function.

My expectation is that how we're initializing the report data doesn't quite match up with the way you expect us to. But that's not something we're really looking to fix, right now. We've made the decision to rewrite the reporting systems using a completely different technology, so putting more than the minimal effort into getting the Telerik reports to not generate errors is not justified.

Is there something I can do, in markup or in code-behind, to keep the navigate buttons from showing?  Or something I can do in the code-behind when we run the report, so that it always thinks that it's been the only instance that has been run?

==== EDITED ====

OK, never mind.   ShowNavigationGroup="false".  Somehow that never showed up, when I was searching around for NavigateBack and NavigateForward.

No answers yet. Maybe you can help?

Tags
General Discussions
Asked by
Jeff
Top achievements
Rank 1
Share this question
or