This is a migrated thread and some comments may be shown as answers.

Navigate to report custom action in HTML5 ReportViewer while changing connectionstring

1 Answer 32 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Christiaan
Top achievements
Rank 1
Christiaan asked on 17 Dec 2017, 04:25 PM

I store the xml layout of the report in my database, and use a custom resolver to create a ReportInstance when rendering the report. This all works great.

But when I start to use the "Navigate to report" action, I can't get it to work. In the winform reportviewer, I see the correct behavior. I can click on the textbox, and the 2nd report renders. Hower in the HTML5 ReportViewer, that textbox is not a click target.

I found this post https://www.telerik.com/forums/html5-reportviewer-navigate-to-reports-action-not-working, which says that it is by design when you use a custom resolver. Is there a workaround to still make it a click-target?

1 Answer, 1 is accepted

Sort by
0
Silviya
Telerik team
answered on 20 Dec 2017, 03:46 PM
Hello Christiaan,

Yes, you are right that this behavior is by design. We will discuss this case further with our development team and see if it is possible to offer a solution for this issue in the future.

Regards,
Silviya
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
General Discussions
Asked by
Christiaan
Top achievements
Rank 1
Answers by
Silviya
Telerik team
Share this question
or